summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-07-05 08:23:28 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-07-05 08:23:28 -0400
commit22644829621e3613ac87a51e1ccac021a096dbc6 (patch)
treefd12e158061862d50804930e63dedeb7484304d0
parent60b19d214d43e11e090f939b330d897f297369c5 (diff)
Load python-support sequence file first, to allow ones loaded later to disable it.
-rw-r--r--debian/changelog7
-rwxr-xr-xdh2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 00d33565..e199eb39 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.0.14) UNRELEASED; urgency=low
+
+ * Load python-support sequence file first, to allow ones loaded later to
+ disable it.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 05 Jul 2008 08:22:43 -0400
+
debhelper (7.0.13) unstable; urgency=low
* dh_auto_install: Rather than looking at the number of binary packages
diff --git a/dh b/dh
index 7a87e1e6..f8e26e56 100755
--- a/dh
+++ b/dh
@@ -293,7 +293,7 @@ $sequences{binary} = [@{$sequences{install}}, qw{
$sequences{'binary-arch'} = [@{$sequences{binary}}];
# --with python-support is enabled by default, at least for now
-push @{$dh{WITH}}, "python-support";
+unshift @{$dh{WITH}}, "python-support";
# sequence addon interface
sub _insert {