summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-03-06 14:11:45 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-03-06 14:11:45 -0500
commit286f89e8dd31f967818011bd141aab46ed71a7e0 (patch)
tree8d2fc578fcb008b80dcfb70f79c852ec97b4d2bd
parent651be44c078b91112bf18d87d3629d23beb1a5c7 (diff)
dh_installdocs: No longer add maintainer script code to call doc-base, as it supports triggers in stable.
-rw-r--r--autoscripts/postinst-doc-base3
-rw-r--r--autoscripts/prerm-doc-base4
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installdocs20
4 files changed, 5 insertions, 24 deletions
diff --git a/autoscripts/postinst-doc-base b/autoscripts/postinst-doc-base
deleted file mode 100644
index 39265721..00000000
--- a/autoscripts/postinst-doc-base
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ "$1" = configure ] && which install-docs >/dev/null 2>&1; then
- install-docs -i /usr/share/doc-base/#DOC-ID#
-fi
diff --git a/autoscripts/prerm-doc-base b/autoscripts/prerm-doc-base
deleted file mode 100644
index c57d999a..00000000
--- a/autoscripts/prerm-doc-base
+++ /dev/null
@@ -1,4 +0,0 @@
-if [ "$1" = remove ] || [ "$1" = upgrade ] && \
- which install-docs >/dev/null 2>&1; then
- install-docs -r #DOC-ID#
-fi
diff --git a/debian/changelog b/debian/changelog
index 09f692c1..0f427fc8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ debhelper (7.2.3) UNRELEASED; urgency=low
* dh_installmenus: Now that a triggers capable menu and dpkg are in
stable, menu does not need to be explicitly run in maintainer
scripts, except for packages with menu-methods files. (See #473467)
+ * dh_installdocs: No longer add maintainer script code to call
+ doc-base, as it supports triggers in stable.
-- Joey Hess <joeyh@debian.org> Fri, 06 Mar 2009 13:57:47 -0500
diff --git a/dh_installdocs b/dh_installdocs
index c20095c0..87954116 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_installdocs> [S<I<debhelper options>>] [B<-A>] [B<-n>] [B<-X>I<item>] [S<I<file ...>>]
+B<dh_installdocs> [S<I<debhelper options>>] [B<-A>] [B<-X>I<item>] [S<I<file ...>>]
=head1 DESCRIPTION
@@ -40,10 +40,8 @@ debian/package.TODO can be used to specify files for subpackages.
Files named debian/package.docs can list other files to be installed.
Files named debian/package.doc-base, will be installed as doc-base control
-files, and will make this program automatically generate the postinst and
-prerm commands needed to interface with the doc-base package. Note that the
-doc-id will be determined from the "Document:" entry in the
-doc-base control file in question.
+files. Note that the doc-id will be determined from the "Document:" entry
+in the doc-base control file in question.
If your package needs to register more than one document, you need multiple
files. To accomplish this, you can use files named debian/package.doc-base.*
@@ -57,10 +55,6 @@ files. To accomplish this, you can use files named debian/package.doc-base.*
Install all files specified by command line parameters in ALL packages
acted on.
-=item B<-n>, B<--noscripts>
-
-Do not modify postinst/prerm scripts.
-
=item B<-Xitem>, B<--exclude=item>
Exclude files that contain "item" anywhere in their filename from
@@ -223,14 +217,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
foreach my $fn (keys %doc_ids) {
doit("install","-g",0,"-o",0,"-m644","-p","debian/$fn",
"$tmp/usr/share/doc-base/$doc_ids{$fn}");
- if (! $dh{NOSCRIPTS}) {
- autoscript($package,"postinst","postinst-doc-base",
- "s/#DOC-ID#/$doc_ids{$fn}/",
- );
- autoscript($package,"prerm","prerm-doc-base",
- "s/#DOC-ID#/$doc_ids{$fn}/",
- );
- }
}
}