summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-09-22 08:00:21 +0000
committerjoey <joey>2005-09-22 08:00:21 +0000
commit29add35a30e5b0aeb2d23b3e2d4b7a05c97c535f (patch)
tree2ca16aee294cffce582ff7a81c0aadde5fd2a4d4
parent2632e573ecb8d02576e17c8ab94b469a3c30f993 (diff)
r1786: releasing version 4.9.9
-rw-r--r--autoscripts/postinst-gconf12
-rw-r--r--autoscripts/prerm-gconf10
-rw-r--r--debian/changelog12
-rwxr-xr-xdh_gconf2
4 files changed, 14 insertions, 22 deletions
diff --git a/autoscripts/postinst-gconf b/autoscripts/postinst-gconf
index a0674bfd..f5e7b2bc 100644
--- a/autoscripts/postinst-gconf
+++ b/autoscripts/postinst-gconf
@@ -1,13 +1,3 @@
if [ "$1" = "configure" ]; then
- SCHEMA_LOCATION=/usr/share/gconf/schemas
- SCHEMA_FILES="#SCHEMAS#"
- for SCHEMA in $SCHEMA_FILES; do
- if [ -e $SCHEMA_LOCATION/$SCHEMA ]; then
- HOME=/root GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
- gconftool-2 \
- --makefile-install-rule $SCHEMA_LOCATION/$SCHEMA > /dev/null
- fi
- done
-
- kill -s HUP `pidof gconfd-2` >/dev/null 2>&1 || true
+ /usr/sbin/gconf-schemas --register #SCHEMAS#
fi
diff --git a/autoscripts/prerm-gconf b/autoscripts/prerm-gconf
index cd755413..18e911ba 100644
--- a/autoscripts/prerm-gconf
+++ b/autoscripts/prerm-gconf
@@ -1,11 +1,3 @@
if [ "$1" = remove ] || [ "$1" = upgrade ]; then
- SCHEMA_LOCATION=/usr/share/gconf/schemas
- SCHEMA_FILES="#SCHEMAS#"
- for SCHEMA in $SCHEMA_FILES; do
- if [ -e $SCHEMA_LOCATION/$SCHEMA ]; then
- HOME=/root GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
- gconftool-2 \
- --makefile-uninstall-rule $SCHEMA_LOCATION/$SCHEMA > /dev/null
- fi
- done
+ /usr/sbin/gconf-schemas --unregister #SCHEMAS#
fi
diff --git a/debian/changelog b/debian/changelog
index 8e147436..b3dccc73 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,20 @@
-debhelper (4.9.9) UNRELEASED; urgency=low
+debhelper (4.9.9) unstable; urgency=low
* dh_shlibdeps: Avoid a use strict warning in some cases if
LD_LIBRARY_PATH is not set.
+ * ACK NMU. Closes: #327209
-- Joey Hess <joeyh@debian.org> Wed, 7 Sep 2005 15:32:53 -0400
+debhelper (4.9.8.1) unstable; urgency=low
+
+ * NMU with maintainer approval.
+ * dh_gconf: delegate schema registration the gconf-schemas script,
+ which moves schemas to /var/lib/gconf, and require gconf2 2.10.1-2,
+ where it can be found. Closes: #327209
+
+ -- Josselin Mouette <joss@debian.org> Wed, 21 Sep 2005 23:39:01 +0200
+
debhelper (4.9.8) unstable; urgency=low
* Spelling patch from Kumar Appaiah. Closes: #324892
diff --git a/dh_gconf b/dh_gconf
index 6c6aa6d9..bd743428 100755
--- a/dh_gconf
+++ b/dh_gconf
@@ -50,7 +50,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
autoscript($package,"postinst","postinst-gconf","s%#SCHEMAS#%$schemas%");
autoscript($package,"prerm","prerm-gconf","s%#SCHEMAS#%$schemas%");
autoscript($package,"postrm","postrm-gconf","s%#SCHEMAS#%$schemas%");
- addsubstvar($package, "misc:Depends", "gconf2 (>= 2.6.2-1)");
+ addsubstvar($package, "misc:Depends", "gconf2 (>= 2.10.1-2)");
}
}
}