summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>1999-08-28 02:16:36 +0000
committerjoey <joey>1999-08-28 02:16:36 +0000
commit2d2000555c6275a0c5af0725abcd27d5a02f22fd (patch)
tree140a7b108e32ffb0a376df97a6c34866e9fc7ebe
parenta511e6823eb67fdc505b75b2a118c4a8b17037fb (diff)
r261: * No user visible changes. Modified the package to interface better with
my new local build system, which auto-updates the home page when a new debhelper is built.
-rw-r--r--Makefile3
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules44
3 files changed, 16 insertions, 39 deletions
diff --git a/Makefile b/Makefile
deleted file mode 100644
index 5efe0a3f..00000000
--- a/Makefile
+++ /dev/null
@@ -1,3 +0,0 @@
-# Take it from here, debian/rules.
-# This whole file could be a symlink, but CVS sucks.
-include debian/rules
diff --git a/debian/changelog b/debian/changelog
index e7846baa..7dd9558a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (2.0.27) unstable; urgency=low
+
+ * No user visible changes. Modified the package to interface better with
+ my new local build system, which auto-updates the home page when a new
+ debhelper is built.
+
+ -- Joey Hess <joeyh@master.debian.org> Thu, 26 Aug 1999 23:20:40 -0700
+
debhelper (2.0.25) unstable; urgency=low
* Corrected debian/fixlinks to make the correct debian/* symlinks needed
diff --git a/debian/rules b/debian/rules
index 09a09a1e..aae9e6b6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,9 +19,8 @@ VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Ver
export DH_VERBOSE=1
-build: link-stamp
- # Run regression tests.
- $(MAKE) test
+build: link-stamp test
+# Nothing to do.
clean: link-stamp
./dh_testdir
@@ -99,43 +98,16 @@ binary-indep: link-stamp build
./dh_md5sums
./dh_builddeb
-# Install in the proper location on my ftp server and web server. Not intended
-# for use by anyone except the author.
-OLD_VER=$(shell perl -e '<>;<>;while(<>){last if /^ --/};<>;$$_=<>;print m/\((.*?)\)/'<debian/changelog)
-dist: commit link-stamp
- dpkg-buildpackage -rfakeroot -tc
- if [ `hostname` = 'kite' ] ; then \
- cp ../debhelper_$(VERSION).tar.gz ../../public; \
- rm /home/ftp/pub/code/debhelper/* || true; \
- cp debian/changelog /home/pub/programs/debhelper/CHANGES; \
- echo $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS; \
- cd ..; rm -rf debhelper-$(OLD_VER); \
- [ -f ../public/debhelper_$(OLD_VER).tar.gz ] && \
- tar zxf ../public/debhelper_$(OLD_VER).tar.gz || \
- tar zxf ../outdated/debhelper_$(OLD_VER).tar.gz; \
- diff -r -u --new-file debhelper-$(OLD_VER) debhelper-$(VERSION) > \
- /home/ftp/pub/code/debhelper/diffs/debhelper-$(VERSION).diff; \
- gzip -9f /home/ftp/pub/code/debhelper/diffs/debhelper-$(VERSION).diff; \
- cd /tmp; rm -f debhelper-$(OLD-VER); \
- fi
-
+# Fix links when checking out of cvs by calling this target.
link-stamp:
sh -e debian/fixlinks
touch link-stamp
-# This is for local use - it tags the current code with the debian version
-# number, then commits the current code using the contents of the changelog
-# as the cvs changelog, then increments the version number
-commit:
- cvs -Q commit -m "`dpkg-parsechangelog | grep '^ '`"
- cvs -Q tag rel-$(shell dpkg-parsechangelog | grep ^Version: \
- |cut -d " " -f 2 |tr '.' '-')
-
-new:
- # Update w/o editing.
- EDITOR=true dch -i 2>/dev/null
- # Dch has to change the bloody directory name. Feh.
- mv . ../debhelper
+# Update the debhelper web page. Not intended for use by anyone except the
+# author.
+installhook:
+ cp debian/changelog /home/pub/programs/debhelper/CHANGES
+ echo $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary dist