summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-11-09 20:43:45 +0000
committerjoey <joey>2005-11-09 20:43:45 +0000
commit32196487a6c9e07e600e4f9f926d1bff83af64fc (patch)
tree0200c6eeb3a96b030b8a3661bb997b7574f8b381
parent466cc4e73bda6aa1347133f3acbf4aaf2cca44cf (diff)
r1818: releasing version 5.0.5
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules10
-rw-r--r--po/debhelper.pot2
-rwxr-xr-x[-rw-r--r--]t/syntax1
4 files changed, 14 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index ec4f43a7..9096a8e1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (5.0.5) unstable; urgency=low
+
+ * Create Dh_Version.pm before running syntax test. Closes: #338337
+
+ -- Joey Hess <joeyh@debian.org> Wed, 9 Nov 2005 15:41:06 -0500
+
debhelper (5.0.4) unstable; urgency=low
* Remove hardcoded paths to update-modules and gconf-schemas in various
diff --git a/debian/rules b/debian/rules
index 0457356a..c9b186ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,7 +32,11 @@ PERLLIBDIR=$(shell perl -MConfig -e 'print $$Config{vendorlib}')
POD2MAN=pod2man -c Debhelper -r "$(VERSION)"
-build: test build-stamp
+version:
+ printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
+ Debian/Debhelper/Dh_Version.pm
+
+build: version test build-stamp
build-stamp:
find . -maxdepth 1 -type f -perm +100 -name "dh_*" \
-exec $(POD2MAN) {} {}.1 \;
@@ -52,8 +56,6 @@ build-stamp:
$(POD2MAN) --section=7 > debhelper.$$lang.7; \
done
- printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
- Debian/Debhelper/Dh_Version.pm
touch build-stamp
clean:
@@ -62,7 +64,7 @@ clean:
./run dh_clean *.1 *.7 *-stamp Debian/Debhelper/Dh_Version.pm
rm -rf man
-test: test-stamp
+test: version test-stamp
test-stamp:
./run dh_clean
./run perl -MTest::Harness -e 'runtests grep { ! /CVS/ && ! /\.svn/ } @ARGV' t/*
diff --git a/po/debhelper.pot b/po/debhelper.pot
index bafb13e0..74062c1b 100644
--- a/po/debhelper.pot
+++ b/po/debhelper.pot
@@ -6,7 +6,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2005-11-08 16:41-0500\n"
+"POT-Creation-Date: 2005-11-09 15:41-0500\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
diff --git a/t/syntax b/t/syntax
index b647b915..76fd46ae 100644..100755
--- a/t/syntax
+++ b/t/syntax
@@ -7,5 +7,6 @@ my @libs=glob("Debian/Debhelper/*.pm");
plan(tests => (@progs + @libs));
foreach my $file (@progs, @libs) {
+ print "# Testing $file\n";
ok(system("perl -c $file >/dev/null 2>&1"), 0);
}