summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-02-17 12:21:01 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-02-17 12:21:01 -0500
commit378b377ef732119de4c2a08dcb9721500b017da1 (patch)
treec8e46d06901320360d52dfde8458d38cbb641534
parentae4994f07656deb47ffc55b8ebd4668c158b9333 (diff)
dh: Support debian/rules calling make with -B
That is useful to avoid issues with phony implicit rules (see bug #509756). Apparently make treats the name of the Makfile as an automaticall set up target, so this causes it to try to build the Makefile even though it's up-to-date, and the implicit target makes it run 'dh debian/rules'. So, make that a no-op.
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules4
-rwxr-xr-xdh6
3 files changed, 11 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index bbabe30f..89403bd8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,9 @@ debhelper (7.2.0) UNRELEASED; urgency=low
* dh: Fix typo. Closes: #509754
* debhelper.pod: Fix typo. Closes: #510180
* dh_gconf: Support mandatory settings. Closes: #513923
+ * dh: Support debian/rules calling make with -B,
+ which is useful to avoid issues with phony implicit
+ rules (see bug #509756).
-- Joey Hess <joeyh@debian.org> Thu, 25 Dec 2008 16:26:36 -0500
diff --git a/debian/rules b/debian/rules
index 03db2d00..ae141867 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,4 @@
-#!/usr/bin/make -f
+#!/usr/bin/make -Bf
# If you're looking for an example debian/rules that uses debhelper, see
# the examples directory.
#
@@ -11,3 +11,5 @@
# Not intended for use by anyone except the author.
announcedir:
@echo ${HOME}/src/joeywiki/code/debhelper/news
+
+.PHONY: build
diff --git a/dh b/dh
index 8938baa4..39b11700 100755
--- a/dh
+++ b/dh
@@ -320,7 +320,11 @@ if (! @ARGV) {
error "specify a sequence to run";
}
my $sequence=shift;
-if (! exists $sequences{$sequence}) {
+if ($sequence eq 'debian/rules') {
+ # make -B causes the rules file to be run as a target
+ exit 0
+}
+elsif (! exists $sequences{$sequence}) {
error "Unknown sequence $sequence (choose from: ".
join(" ", sort keys %sequences).")";
}