summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-10-28 18:30:24 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-10-28 18:30:24 -0400
commit3c3ebf1ba6a7e93f7fb66d375ca8c1106d99af2c (patch)
tree5ace15e2b4ef510967f8db75e8d99f37d8f0c313
parent17bf50c840dcbc9cece5b6a18ed0fe1574bf99a0 (diff)
remove implicit --parallel setting by dh
-rw-r--r--debhelper.pod3
-rw-r--r--debian/changelog4
-rwxr-xr-xdh25
3 files changed, 3 insertions, 29 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 238675ab..20ca9d7d 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -214,9 +214,6 @@ variable (as per Debian Policy section 4.9.1).
The number of parallel processes will be the smaller value specified by
I<--parallel>, DEB_BUILD_OPTIONS, or a build system specific limit.
-So, I<--parallel=1> can be used to disable parallel building, or a larger
-number can be specified if a package is known to only successfully build
-with a limited number of parallel processes.
=item B<--list>, B<-l>
diff --git a/debian/changelog b/debian/changelog
index d164f73b..9d1f81fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,8 @@ debhelper (7.4.4) UNRELEASED; urgency=low
and the build system supports it, parallel building is done.
* The makefile buildsystem (and derived buildsystems) now supports
parallel building.
- * dh: If --parallel is not explicitly specified, enable it anyway.
- Closes: #532805.
+ * Typically, to enable parallel building, the --parallel option will
+ be passed to dh. Closes: #532805
* Thanks, Modestas Vainius for most of the work on parallel build support.
-- Joey Hess <joeyh@debian.org> Wed, 28 Oct 2009 18:10:45 -0400
diff --git a/dh b/dh
index 775e9492..0ecfe442 100755
--- a/dh
+++ b/dh
@@ -41,13 +41,6 @@ override target can then run the command with additional options, or run
entirely different commands instead. (Note that to use this feature,
you should Build-Depend on debhelper 7.0.50 or above.)
-dh passes --parallel to dh_auto_* commands if it detects being run by the
-C<dpkg-buildpackage -jX> command, but a job server of the parent I<make>
-(presumably debian/rules) is not reachable. Nonetheless, it is highly
-recommended to pass --parallel/-j option to dh explicitly to indicate that a
-source package supports parallel building. See L<debhelper(7)/"BUILD SYSTEM
-OPTIONS"> for more information.
-
=head1 OPTIONS
=over 4
@@ -229,8 +222,6 @@ init(options => {
},
"l" => \$dh{LIST},
"list" => \$dh{LIST},
- "j:i" => \$dh{PARALLEL},
- "parallel:i" => \$dh{PARALLEL},
});
inhibit_log();
@@ -239,9 +230,6 @@ inhibit_log();
# server.
if (is_make_jobserver_unavailable()) {
clean_jobserver_makeflags();
- # Implicitly enable parallel (no maximum) if a value was not previously
- # specified.
- $dh{PARALLEL} = 0 unless defined $dh{PARALLEL};
}
# Definitions of sequences.
@@ -450,12 +438,7 @@ while (@ARGV_orig) {
shift @ARGV_orig;
next;
}
- elsif ($opt =~ /^--?(no-act|remaining|(after|until|before|with|without|parallel)=)/) {
- next;
- }
- elsif ($opt =~ /^(-j|--parallel)$/) {
- # Argument to -j/--parallel is optional.
- shift @ARGV_orig if @ARGV_orig > 0 && $ARGV_orig[0] =~ /^\d+$/;
+ elsif ($opt =~ /^--?(no-act|remaining|(after|until|before|with|without)=)/) {
next;
}
push @options, $opt;
@@ -536,12 +519,6 @@ sub run {
# to prevent them from being acted on.
push @options, map { "-N$_" } @exclude;
- # Pass --parallel to dh_auto_* commands.
- if (defined $dh{PARALLEL} && $dh{PARALLEL} != 1
- && $command =~ /^dh_auto_/) {
- push @options, "--parallel" . ($dh{PARALLEL} > 1 ? "=$dh{PARALLEL}" : "");
- }
-
# Check for override targets in debian/rules and
# run them instead of running the command directly.
my $override_command;