summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-02-05 18:09:36 +0000
committerjoey <joey>2001-02-05 18:09:36 +0000
commit418435f110b5f39e6933272e051e15d919ef59b9 (patch)
tree6f7b1a57c2797d2eb5a487d655c759fc99fa19bc
parent6648880ed40453cd7df9ad8a6a73e58e455dad92 (diff)
r417: * dh_installinit -r: stop init script in prerm on package removal,
Closes: #84974
-rw-r--r--autoscripts/prerm-init-norestart3
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installinit4
3 files changed, 13 insertions, 1 deletions
diff --git a/autoscripts/prerm-init-norestart b/autoscripts/prerm-init-norestart
new file mode 100644
index 00000000..ec9820f8
--- /dev/null
+++ b/autoscripts/prerm-init-norestart
@@ -0,0 +1,3 @@
+if [ "$1" = remove ]; then
+ /etc/init.d/#SCRIPT# stop
+fi
diff --git a/debian/changelog b/debian/changelog
index 4d6f2134..7a4a8954 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.2.20) unstable; urgency=low
+
+ * dh_installinit -r: stop init script in prerm on package removal,
+ Closes: #84974
+
+ -- Joey Hess <joeyh@debian.org> Mon, 5 Feb 2001 10:06:31 -0800
+
debhelper (2.2.19) unstable; urgency=low
* dh_shlibdeps -l can handle relative paths now. Patch from Colin Watson
diff --git a/dh_installinit b/dh_installinit
index 7836a9e2..cd3fca48 100755
--- a/dh_installinit
+++ b/dh_installinit
@@ -55,10 +55,12 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
# -r on the command line sets R_FLAG. If it's set, there
# is no restart on upgrade.
if ($dh{R_FLAG}) {
- autoscript($PACKAGE,"postinst","postinst-init-norestart",
+ autoscript($PACKAGE,"postinst", "postinst-init-norestart",
"s/#SCRIPT#/$script/;s/#INITPARMS#/$params/");
autoscript($PACKAGE,"postrm","postrm-init",
"s/#SCRIPT#/$script/;s/#INITPARMS#/$params/");
+ autoscript($PACKAGE,"prerm","prerm-init-norestart",
+ "s/#SCRIPT#/$script/;s/#INITPARMS#/$params/");
}
else {
autoscript($PACKAGE,"postinst","postinst-init",