summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-06-11 18:55:40 +0300
committerModestas Vainius <modestas@vainius.eu>2009-06-11 19:01:39 +0300
commit45d6698e772aa6990d6b27a98325cc228d7004fd (patch)
tree85136bde5f675032e306f411496bffb581afd3d0
parentddcbef2b31fc7689b67916beaf265bea8ebef187 (diff)
Ship Debian/Debhelper/Buildsystem/* in the package.
Signed-off-by: Modestas Vainius <modestas@vainius.eu>
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index fe81c8c1..f13b3fc9 100644
--- a/Makefile
+++ b/Makefile
@@ -63,11 +63,13 @@ clean:
install:
install -d $(DESTDIR)/usr/bin \
$(DESTDIR)/usr/share/debhelper/autoscripts \
- $(DESTDIR)$(PERLLIBDIR)/Sequence
+ $(DESTDIR)$(PERLLIBDIR)/Sequence \
+ $(DESTDIR)$(PERLLIBDIR)/Buildsystem
install $(shell find -maxdepth 1 -mindepth 1 -name dh\* |grep -v \.1\$$) $(DESTDIR)/usr/bin
install -m 0644 autoscripts/* $(DESTDIR)/usr/share/debhelper/autoscripts
install -m 0644 Debian/Debhelper/*.pm $(DESTDIR)$(PERLLIBDIR)
install -m 0644 Debian/Debhelper/Sequence/*.pm $(DESTDIR)$(PERLLIBDIR)/Sequence
+ install -m 0644 Debian/Debhelper/Buildsystem/*.pm $(DESTDIR)$(PERLLIBDIR)/Buildsystem
test: version
./run perl -MTest::Harness -e 'runtests grep { ! /CVS/ && ! /\.svn/ && -f && -x } @ARGV' t/* t/buildsystems/*