summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-02-14 14:22:14 -0400
committerJoey Hess <joey@kitenet.net>2011-02-14 14:22:14 -0400
commit4a7ce74b4a790dfea5d69cab9a5a7d8f89693232 (patch)
tree9bc568418d3bb96b208852a13b6a4a7dbd7e6073
parent462d30c34c365863606d9fb454b49251a9b4bf9b (diff)
Fix logging at end of an override target that never actually runs the overridden command. Closes: #613418
-rw-r--r--debian/changelog7
-rwxr-xr-xdh2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 58e8d55e..06adf08e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (8.1.2) UNRELEASED; urgency=low
+
+ * Fix logging at end of an override target that never actually runs
+ the overridden command. Closes: #613418
+
+ -- Joey Hess <joeyh@debian.org> Mon, 14 Feb 2011 14:21:38 -0400
+
debhelper (8.1.1) unstable; urgency=low
* dh_strip, dh_makeshlibs: use triplet-objdump, triplet-objcopy and
diff --git a/dh b/dh
index 9e6fa04e..5a6679e5 100755
--- a/dh
+++ b/dh
@@ -689,8 +689,8 @@ sub run {
if ($override_command ne 'dh_clean') {
my %packages=map { $_ => 1 } @packages;
map { delete $packages{$_} } @exclude;
- commit_override_log(keys %packages);
write_log($override_command, keys %packages);
+ commit_override_log(keys %packages);
}
delete $ENV{DH_INTERNAL_OPTIONS};