summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-05-11 14:51:03 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-05-11 14:51:03 -0400
commit4e6b4536d7611a303b4e57de932dce5bd07ee93f (patch)
tree3512bc51cb2597a5301ddb35c8db347d6056c110
parentdd0ea070fcb2935b570dda4677039901cf601799 (diff)
dh: Support --with addon,addon,... Closes: #528178
-rw-r--r--debian/changelog7
-rwxr-xr-xdh9
2 files changed, 12 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index e8150273..22bc55ba 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.2.11) UNRELEASED; urgency=low
+
+ * dh: Support --with addon,addon,...
+ Closes: #528178
+
+ -- Joey Hess <joeyh@debian.org> Mon, 11 May 2009 14:50:33 -0400
+
debhelper (7.2.10) unstable; urgency=low
* Close COMPAT_IN filehandle. Closes: #527464
diff --git a/dh b/dh
index ea1605f1..701f588e 100755
--- a/dh
+++ b/dh
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh> sequence [B<--with> I<addon>] [B<--until> I<cmd>] [B<--before> I<cmd>] [B<--after> I<cmd>] [B<--remaining>] [S<I<debhelper options>>]
+B<dh> sequence [B<--with> I<addon>[,I<addon>,...]] [B<--until> I<cmd>] [B<--before> I<cmd>] [B<--after> I<cmd>] [B<--remaining>] [S<I<debhelper options>>]
=head1 DESCRIPTION
@@ -45,11 +45,12 @@ you should Build-Depend on debhelper 7.0.50 or above.)
=over 4
-=item B<--with> I<addon>
+=item B<--with> I<addon>[,I<addon>,...]
Add the debhelper commands specified by the given addon to appropriate places
in the sequence of commands that is run. This option can be repeated more
-than once, and is used when there is a third-party package that provides
+than once, or multiple addons can be listed, separated by commas.
+This is used when there is a third-party package that provides
debhelper commands. See the PROGRAMMING file for documentation about
the sequence addon interface.
@@ -194,7 +195,7 @@ init(options => {
"remaining" => \$dh{REMAINING},
"with=s" => sub {
my ($option,$value)=@_;
- push @{$dh{WITH}},$value;
+ push @{$dh{WITH}},split(",", $value);
},
"without=s" => sub {
my ($option,$value)=@_;