summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2009-09-27 22:12:26 -0400
committerJoey Hess <joey@kitenet.net>2009-09-27 22:12:26 -0400
commit4eb727d47ff6e04eb1634ca66df191bbf69e2009 (patch)
tree0e9750738cb2648ed9201ae9d4c0cf18adfa98d5
parent9e6f102b429e59450bc66cd567c5454c70c181b1 (diff)
parent93ff23687656aa24a68a29eb30908974e55da3ef (diff)
Merge branch 'master' of ssh://git.debian.org/git/debhelper/debhelper
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debian/changelog5
2 files changed, 5 insertions, 2 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 5a0b7947..325c7fc3 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -608,7 +608,7 @@ sub excludefile {
sub dpkg_architecture_value {
my $var = shift;
- my $value=`dpkg-architecture -q$var 2>/dev/null` || error("dpkg-architecture failed");
+ my $value=`dpkg-architecture -q$var` || error("dpkg-architecture failed");
chomp $value;
return $value;
}
diff --git a/debian/changelog b/debian/changelog
index 02b0c5f9..31456106 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,11 +3,14 @@ debhelper (7.4.3) UNRELEASED; urgency=low
[ Valery Perrin ]
* update french translation. Closes: #494300, #477703
* add --previous at po4a command into Makefile
- * add dh, dh_auto_install, dh_auto_clean, dh_auto_configure, dh_auto_install, dh_auto_test, dh_bugfiles, dh_icons, dh_installifupdown, dh_installudev, dh_lintian, dh_prep into po4a.cfg manpages list
+ * add dh, dh_auto_install, dh_auto_clean, dh_auto_configure,
+ dh_auto_install, dh_auto_test, dh_bugfiles, dh_icons, dh_installifupdown,
+ dh_installudev, dh_lintian, dh_prep into po4a.cfg manpages list
[ Joey Hess ]
* dh_perl: Do not look at perl scripts under /usr/share/doc.
Closes: #546683
+ * Allow dpkg-architecture to print errors to stderr. Closes: #548636
-- Joey Hess <joeyh@debian.org> Tue, 15 Sep 2009 13:18:35 -0400