summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-02-23 13:31:11 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-02-23 13:31:11 -0500
commit5029340ae819bc949f68d2c76e83fe135f4d1ca8 (patch)
tree30dfba3e4adeb3cb4fad6f78ae9ec06635009936
parent3ba936471c4e6eef1134de0539824b1d21d66646 (diff)
dh_gencontrol: No longer need to generate the udeb filename when calling dpkg-gencontrol.
* dh_gencontrol: No longer need to generate the udeb filename when calling dpkg-gencontrol. * dh_gencontrol: Do not need to tell dpkg-gencontol not to include the Homepage field in udebs (fixed in dpkg-dev 1.14.17).
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_gencontrol4
2 files changed, 4 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 8fde13b7..fcd990be 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -17,6 +17,10 @@ debhelper (7.2.0) UNRELEASED; urgency=low
* Improve error messages when child commands fail.
* Depend on dpkg-dev 1.14.19, the first to support Package-Type
fields in dpkg-gencontrol.
+ * dh_gencontrol: No longer need to generate the udeb filename
+ when calling dpkg-gencontrol.
+ * dh_gencontrol: Do not need to tell dpkg-gencontol not to
+ include the Homepage field in udebs (fixed in dpkg-dev 1.14.17).
-- Joey Hess <joeyh@debian.org> Thu, 25 Dec 2008 16:26:36 -0500
diff --git a/dh_gencontrol b/dh_gencontrol
index abecc1eb..726d0855 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -66,10 +66,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (getpackages() > 1) {
push @command, "-p$package";
}
- if (is_udeb($package)) {
- push @command, "-UHomepage";
- push @command, "-n".udeb_filename($package);
- }
doit(@command, "-l$changelog", "-T$substvars",
"-P$tmp",@{$dh{U_PARAMS}});