summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2009-08-06 12:12:04 -0400
committerJoey Hess <joey@kitenet.net>2009-08-06 12:12:04 -0400
commit50fb7898bb603e07429d42d181fc9525b83b233f (patch)
tree3cf0fc6df5e1fbb9513543fa33bd5927689f9229
parent8bea5baf77f7d0cd56d4c66c4c3f7c33d28b506a (diff)
parent18a5bea209de05d47df17a731634eab21f991d4e (diff)
Merge branch 'master' of ssh://git.debian.org/git/debhelper/debhelper
-rw-r--r--debian/changelog8
-rwxr-xr-xdh5
-rw-r--r--doc/PROGRAMMING7
3 files changed, 19 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index ae3846c3..954cfb03 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (7.3.12) unstable; urgency=low
+
+ * dh: Allow creation of new sequences (such as to handle a patch
+ target for quilt), by adding an add_command function to the
+ sequence addon interface. See #540124.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 06 Aug 2009 11:08:53 -0400
+
debhelper (7.3.11) unstable; urgency=low
* perl_build: Fix Build check to honor source directory setting.
diff --git a/dh b/dh
index c34a5a02..2a6c0a31 100755
--- a/dh
+++ b/dh
@@ -322,6 +322,11 @@ sub remove_command {
}
}
+sub add_command {
+ my $command=shift;
+ my $sequence=shift;
+ unshift @{$sequences{$sequence}}, $command;
+}
foreach my $addon (@{$dh{WITH}}) {
my $mod="Debian::Debhelper::Sequence::$addon";
$mod=~s/-/_/g;
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index 4e7ea463..4be09b1c 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -263,7 +263,12 @@ insert_after($existing_command, $new_command)
Insert $new_command in sequences after $existing_command
remove_command($existing_command)
- Remove $existing_command from the list of commands to run.
+ Remove $existing_command from the list of commands to run
+ in all sequences.
+
+add_command($new_command, $sequence)
+ Add $new_command to the beginning of the specified sequence.
+ If the sequence does not exist, it will be created.
Buildsystem Classes:
-------------------