summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-08-16 12:56:01 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-08-16 12:56:01 -0400
commit5e3b38634b5b0a24b30d59b13ac7164dc613afb0 (patch)
tree5a4d9c66a1841a84ef645589bbce0096f8bf4c80
parent90353894282ef4b8327a941798c850029b7a309e (diff)
dh: Display $@ error if addon load fails. Closes: #541845
-rw-r--r--debian/changelog1
-rwxr-xr-xdh2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2df2c624..56f3b400 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ debhelper (7.3.14) UNRELEASED; urgency=low
[ Joey Hess ]
* Run pod2man with --utf8. Closes: #541270
+ * dh: Display $@ error if addon load fails. Closes: #541845
-- Colin Watson <cjwatson@debian.org> Thu, 13 Aug 2009 09:00:24 +0100
diff --git a/dh b/dh
index 9a6af325..bdd78c52 100755
--- a/dh
+++ b/dh
@@ -362,7 +362,7 @@ foreach my $addon (@{$dh{WITH}}) {
$mod=~s/-/_/g;
eval "use $mod";
if ($@) {
- error("--with $addon not supported or failed to load module $mod");
+ error("unable to load addon $addon: $@");
}
}