summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-05-08 01:26:39 +0000
committerjoey <joey>2001-05-08 01:26:39 +0000
commit653a744c8e6b4011874b79757129dae45f5bc229 (patch)
treef45529058f98b58f349e078ec4c71f02f54e6b83
parentb352136551fb3384722942f0206419ca066dedda (diff)
r464: * Now uses html2text rather than lynx for converting html changelogs.
The program generates better results, and won't annoy the people who were oddly annoyed at having to install lynx. Instead, it will annoy a whole other set of people, I'm sure. Closes: #93747
-rw-r--r--debian/changelog9
-rw-r--r--debian/control13
-rwxr-xr-xdh_installchangelogs4
3 files changed, 18 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index efc73e22..93b19999 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (3.0.19) unstable; urgency=low
+
+ * Now uses html2text rather than lynx for converting html changelogs.
+ The program generates better results, and won't annoy the people who
+ were oddly annoyed at having to install lynx. Instead, it will annoy a
+ whole other set of people, I'm sure. Closes: #93747
+
+ -- Joey Hess <joeyh@debian.org> Mon, 7 May 2001 21:23:46 -0400
+
debhelper (3.0.18) unstable; urgency=low
* dh_perl: updates from bod:
diff --git a/debian/control b/debian/control
index 9dca1704..6be4f678 100644
--- a/debian/control
+++ b/debian/control
@@ -3,15 +3,16 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl-5.6, fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils
-Standards-Version: 3.5.3.0
+Standards-Version: 3.5.4.0
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0), lynx, debconf-utils, binutils
+Depends: ${perl:Depends}, fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0), html2text, debconf-utils, binutils
Suggests: dh-make
Description: helper programs for debian/rules
A collection of programs that can be used in a debian/rules file to
- automate common tasks related to building binary debian packages. Programs
- are included to install various files into your package, compress files, fix
- file permissions, integrate your package with the debian menu system,
- suidmanager, doc-base, etc.
+ automate common tasks related to building debian packages. Programs
+ are included to install various files into your package, compress
+ files, fix file permissions, integrate your package with the debian
+ menu system, suidmanager, doc-base, etc. Most debian packages use
+ debhelper as part of their build process.
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 76dd1c19..b0c6c50e 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -30,7 +30,7 @@ not a native debian package, then this upstream changelog will be installed
as usr/share/doc/package/changelog in the package build directory. If the
changelog is a html file (determined by file extension), it will be
installed as usr/share/doc/package/changelog.html instead, and will be
-converted to plain text with lynx to generate
+converted to plain text with html2text to generate
usr/share/doc/package/changelog.
=head1 OPTIONS
@@ -100,7 +100,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# HTML changelog
doit("install","-o",0,"-g",0,"-p","-m644",
$upstream,"$tmp/usr/share/doc/$package/changelog.html");
- complex_doit("lynx -dump $upstream > $tmp/usr/share/doc/$package/changelog");
+ doit("html2text","-nobs","-o","$tmp/usr/share/doc/$package/changelog",$upstream);
$link_to='changelog.html';
}
else {