summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-10-05 17:55:42 +0000
committerjoey <joey>2002-10-05 17:55:42 +0000
commit65ccc28c2f9abfdf88e7250b55ce3b7561e68a6f (patch)
tree012496bcbfa781e32a91cb380411e17f04e945d7
parent09f9fc78318d6f9219ff1f457abe5ff050eb6ea1 (diff)
r554: * dh_fixperms: Make sure .pm files are 0644. Closes: #163418
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_fixperms16
2 files changed, 17 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 4e79590d..0903a8b3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (4.1.14) unstable; urgency=low
+
+ * dh_fixperms: Make sure .pm files are 0644. Closes: #163418
+
+ -- Joey Hess <joeyh@debian.org> Sat, 5 Oct 2002 14:03:52 -0400
+
debhelper (4.1.13) unstable; urgency=low
* dh_installdebconf: Support po-debconf debian/po directories.
diff --git a/dh_fixperms b/dh_fixperms
index 145d7361..39001a54 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -68,6 +68,17 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
complex_doit("find $tmp/usr/share/man $tmp/usr/man/ $tmp/usr/X11*/man/ -type f",
"$find_options -print0 2>/dev/null | xargs -0r chmod 644");
+ # ..and so are executable shared and static libraries
+ # (and .la files from libtool) ..
+ complex_doit("find $tmp -perm -5 -type f",
+ "\\( -name '*.so*' -or -name '*.la' -or -name '*.a' \\) $find_options -print0",
+ "2>/dev/null | xargs -0r chmod 644");
+
+ # .. and perl modules.
+ complex_doit("find $tmp/usr/lib/perl5 $tmp/usr/share/perl5 -type f",
+ "-perm -5 -name '*.pm' $find_options -print0",
+ "2>/dev/null | xargs -0r chmod a-X");
+
# v4 only
if (! compat(3)) {
# Programs in the bin and init.d dirs should be executable..
@@ -79,11 +90,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
}
- # ..and so are executable shared and static libraries
- # (and .la files from libtool)
- complex_doit("find $tmp -perm -5 -type f",
- "\\( -name '*.so*' -or -name '*.la' -or -name '*.a' \\) $find_options -print0",
- "2>/dev/null | xargs -0r chmod a-X");
}
=head1 SEE ALSO