summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2009-08-04 15:12:23 -0400
committerJoey Hess <joey@kitenet.net>2009-08-04 15:12:23 -0400
commit6667158d89b601424b46cb58478922a91620f7e6 (patch)
tree99458aa3aa435424cadb66a933ad11d1d277d313
parent53f442c638cf3c8a7e40a25f72c21c342640454e (diff)
parentd2be218a4b4a5e2e25659db1e5438b0fca6b83e0 (diff)
Merge branch 'master' of ssh://git.debian.org/git/debhelper/debhelper
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm4
-rw-r--r--debian/changelog8
2 files changed, 11 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index caba9b75..88bcff58 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -61,7 +61,9 @@ sub install {
sub clean {
my $this=shift;
- $this->do_perl("Build", "--allow_mb_mismatch", 1, "distclean", @_);
+ if (-f "Build") {
+ $this->do_perl("Build", "--allow_mb_mismatch", 1, "distclean", @_);
+ }
}
1
diff --git a/debian/changelog b/debian/changelog
index 20667098..9fa71cf2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (7.3.10) UNRELEASED; urgency=low
+
+ * perl_build: Avoid failing if forced to be used in dh_auto_clean
+ when Build does not exist (ie due to being run twice in a row).
+ Closes: #539848
+
+ -- Joey Hess <joeyh@debian.org> Tue, 04 Aug 2009 13:19:31 -0400
+
debhelper (7.3.9) unstable; urgency=low
* cmake: Avoid forcing rpath off as this can break some test suites.