summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-08-20 12:46:16 -0400
committerJoey Hess <joey@kitenet.net>2013-08-20 12:46:16 -0400
commit67b82f4b657afbdca04fc3ea4771c78b3d500f0f (patch)
tree1c5fd5498f18e78dbd2919f61195897ac3c3c5a5
parent71d06996481c6187b016c3b14b7e9faaf8adc432 (diff)
makefile buildsystem: Tighten heuristic to detect if makefile target exists. An error message that some other target does not exist just means the makefile spaghetti has problems later on when run with -n, but not that the called target didn't exist. Closes: #718121
-rw-r--r--Debian/Debhelper/Buildsystem/makefile.pm2
-rw-r--r--debian/changelog4
2 files changed, 5 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/makefile.pm b/Debian/Debhelper/Buildsystem/makefile.pm
index a7a3d429..dcc5da87 100644
--- a/Debian/Debhelper/Buildsystem/makefile.pm
+++ b/Debian/Debhelper/Buildsystem/makefile.pm
@@ -61,7 +61,7 @@ sub exists_make_target {
return defined $output
&& length $output
- && $output !~ /\*\*\* No rule to make target/;
+ && $output !~ /\*\*\* No rule to make target `\Q$target\E'/;
}
sub do_make {
diff --git a/debian/changelog b/debian/changelog
index b1f1370d..3e3dd5ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,10 @@ debhelper (9.20130631) UNRELEASED; urgency=low
* dh_install, dh_installdocs, dh_clean: Fix uses of find -exec
which cause it to ignore exit status of the commands run.
Closes: 719598
+ * makefile buildsystem: Tighten heuristic to detect if makefile target
+ exists. An error message that some other target does not exist just means
+ the makefile spaghetti has problems later on when run with -n,
+ but not that the called target didn't exist. Closes: #718121
-- Joey Hess <joeyh@debian.org> Fri, 19 Jul 2013 18:47:27 -0400