summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-06-13 16:14:59 -0400
committerJoey Hess <joey@kitenet.net>2011-06-13 16:14:59 -0400
commit6d12631c2e78f48544277660f981272444ca4df0 (patch)
tree9872c56c4a5051f544f0584ecdc436297317e0d2
parent6e31814343d8564508e66d3de0585feb7e69bfd8 (diff)
move dh_auto_configure out of @bd_minimal
Callers overriding build targets will need to configure by hand or by calling dh_auto_configure, which should be the status quo. And moving dh_auto_configure to build (and build-arch and build-indep) will not make it run twice AFAICS (except for the edge case when it already did: debian/rules build-arch build-indep)
-rwxr-xr-xdh12
1 files changed, 7 insertions, 5 deletions
diff --git a/dh b/dh
index fd137379..dcf3b9c6 100755
--- a/dh
+++ b/dh
@@ -340,12 +340,13 @@ if (is_make_jobserver_unavailable()) {
my %sequences;
my @bd_minimal = qw{
dh_testdir
- dh_auto_configure
};
-my @bd = (@bd_minimal, qw{
+my @bd = qw{
+ dh_testdir
+ dh_auto_configure
dh_auto_build
dh_auto_test
-});
+ };
# rules:build-arch and rules:build-indep are not called by build,
# as an optimisation (code below will adjust this if explicit targets exist).
$sequences{build} = [@bd];
@@ -359,7 +360,8 @@ $sequences{clean} = [qw{
my @i_minimal = qw{
dh_testroot
};
-my @i = (@i_minimal, qw{
+my @i = qw{
+ dh_testroot
dh_prep
dh_installdirs
dh_auto_install
@@ -399,7 +401,7 @@ my @i = (@i_minimal, qw{
dh_link
dh_compress
dh_fixperms
-});
+};
# The install sequences will call rules:build before running
# the standard sequence. rules:install-arch and rules:install-indep
# are not called by install, as an optimisation (code below will adjust