summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-03-07 14:50:29 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-03-07 14:50:29 -0500
commit723a2f85edbd6c1f270bb89a5e4acee90fd277dc (patch)
treef5cac3b8cee322cefc0848f6f8118eb745bbfb77
parent2c863ff2be2ae39ae449962e5abe48dca542fa1d (diff)
Compatability level 4 is now deprecated.
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debhelper.pod2
-rw-r--r--debian/changelog7
-rw-r--r--doc/TODO2
4 files changed, 8 insertions, 5 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index a11c36a..4005494 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -299,7 +299,7 @@ sub dirname {
}
if ($c < 4 && ! $warned_compat) {
- warning("Compatibility levels before 4 are deprecated.");
+ warning("Compatibility levels before 5 are deprecated.");
$warned_compat=1;
}
diff --git a/debhelper.pod b/debhelper.pod
index de2a053..77ace5c 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -333,6 +333,8 @@ dh_link will correct existing links to conform with policy.
=back
+This mode is deprecated.
+
=item V5
Changes from V4 are:
diff --git a/debian/changelog b/debian/changelog
index 4a2e258..d3f23f7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,11 +5,12 @@ debhelper (7.2.3-1) UNRELEASED; urgency=low
scripts, except for packages with menu-methods files. (See #473467)
* dh_installdocs: No longer add maintainer script code to call
doc-base, as it supports triggers in stable.
- * dh: Override LC_ALL, not LANG. Closes: #517617
- * dh_installchangelogs: Support -X to exclude automatic installation
- of specific upstream changelogs. Closes: #490937
* dh_bugfiles: New program, contributed by Modestas Vainius.
Closes: #326874
+ * dh: Override LC_ALL, not LANG. re-Closes: #517617
+ * dh_installchangelogs: Support -X to exclude automatic installation
+ of specific upstream changelogs. re-Closes: #490937
+ * Compatability level 4 is now deprecated.
-- Joey Hess <joeyh@debian.org> Fri, 06 Mar 2009 13:57:47 -0500
diff --git a/doc/TODO b/doc/TODO
index 71fda9f..40fafbb 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -12,7 +12,7 @@ v8:
Deprecated:
-* DH_COMPAT 1, 2, 3. Can be removed once all packages are seen to be using
+* DH_COMPAT 1, 2, 3, 4. Can be removed once all packages are seen to be using
a newer version. I won't hold my breath. Now with evil warning messages
though.
* Also, grep the entire archive for all dh_* command lines,