summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-12-09 13:53:45 -0400
committerJoey Hess <joey@kitenet.net>2011-12-09 13:53:45 -0400
commit77b80367ad0cfdbb3d78242fda3127559e2df576 (patch)
tree26c2ee273f2a52d49f2471fca35825fb582b8f66
parent7f60d2959323bdd6010ec2225a332a4823b8e212 (diff)
Only enable executable config files in v9. The quality of file permissions in debian/ directories turns out to be atrocious; who knew?
-rw-r--r--Debian/Debhelper/Dh_Lib.pm3
-rw-r--r--debhelper.pod5
-rw-r--r--debian/changelog6
3 files changed, 11 insertions, 3 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index a86688a2..3940c05f 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -613,7 +613,8 @@ sub filedoublearray {
my $file=shift;
my $globdir=shift;
- my $x=-x $file;
+ # executable confi files are a v9 thing.
+ my $x=! compat(8) && -x $file;
if ($x) {
require Cwd;
my $cmd=Cwd::abs_path($file);
diff --git a/debhelper.pod b/debhelper.pod
index 72234ca7..dc2295c1 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -514,6 +514,11 @@ F<Build.PL>
B<dh_strip> puts separated debug symbols in a location based on their
build-id.
+=item -
+
+Executable debconf config files are run and their output used as the
+configuration.
+
=back
=back
diff --git a/debian/changelog b/debian/changelog
index 43c9d4a6..682700a5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,13 @@
-debhelper (8.9.13) UNRELEASED; urgency=low
+debhelper (8.9.13) unstable; urgency=low
* Pass CPPFLAGS to qmake. Closes: #646129 Thanks, Felix Geyert
* dh_strip: Use build-id in /usr/lib/debug in v9.
Closes: #642158 Thanks, Jakub Wilk
* Spanish translation update. Closes: #636245 Thanks, Omar Campagne
+ * Only enable executable config files in v9. The quality of file permissions
+ in debian/ directories turns out to be atrocious; who knew?
- -- Joey Hess <joeyh@debian.org> Thu, 08 Dec 2011 18:27:02 -0400
+ -- Joey Hess <joeyh@debian.org> Fri, 09 Dec 2011 13:53:38 -0400
debhelper (8.9.12) unstable; urgency=low