summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-05-18 12:49:10 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-05-18 12:49:10 -0400
commit783e5fded73bc32dc46c2e01e00c898ca70c4977 (patch)
tree98258f704b1b970b1341156b0b169842828e588a
parent70c804bc4a75c7b68d787484ccd22291494c6074 (diff)
dh: Avoid writing log after override_dh_clean is run. Closes: #529228
-rw-r--r--debian/changelog6
-rwxr-xr-xdh10
2 files changed, 13 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 08ed8266..e6882e71 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.2.14) UNRELEASED; urgency=low
+
+ * dh: Avoid writing log after override_dh_clean is run. Closes: #529228
+
+ -- Joey Hess <joeyh@debian.org> Mon, 18 May 2009 12:48:37 -0400
+
debhelper (7.2.13) unstable; urgency=low
* dh_auto_configure: Pass --skipdeps safely via PERL_AUTOINSTALL.
diff --git a/dh b/dh
index 701f588e..d1885101 100755
--- a/dh
+++ b/dh
@@ -471,9 +471,13 @@ sub run {
# Need to handle logging for overriden commands here,
# because the actual debhelper command may not have
# been run by the rules file target.
- my %packages=map { $_ => 1 } @packages;
- map { delete $packages{$_} } @exclude;
- write_log($override_command, keys %packages);
+ # (But avoid logging for dh_clean since it removes
+ # the log earlier.)
+ if ($override_command ne 'dh_clean') {
+ my %packages=map { $_ => 1 } @packages;
+ map { delete $packages{$_} } @exclude;
+ write_log($override_command, keys %packages);
+ }
}
}
}