summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-05-09 10:42:24 -0400
committerJoey Hess <joey@kitenet.net>2013-05-09 10:42:24 -0400
commit7a0f4f35ba52befd343589f06abe5ff1b68dfcf2 (patch)
treeb36264fb0178e6a6a0080868fc2d08ea9ed26e99
parent136f0c7517ce5bffbbebec5bf710fc810510f3bd (diff)
dh_auto_install: Create package build directory for those packages whose makefile falls over otherwise. Closes: #707336
-rw-r--r--debian/changelog11
-rwxr-xr-xdh_auto_install7
2 files changed, 14 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index f917d82c..1c9ed3fc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-debhelper (9.20130508) UNRELEASED; urgency=low
+debhelper (9.20130509) unstable; urgency=low
* dh_installinit: Remove obsolete systemd-tempfiles hack in postinst
autoscript. Closes: #707159
@@ -8,10 +8,13 @@ debhelper (9.20130508) UNRELEASED; urgency=low
not exist. (Audited all the rest.)
* dh: As a workaround for anything not in debhelper that may rely
on debhelper command that is now skipped creating the package build
- directory, the directory is created when a command is skipped.
- This workaround is disabled in compat level 10. Closes: #707336
+ directory as a side effect, the directory is created when a command
+ is skipped. This workaround is disabled in compat level 10.
+ Closes: #707336
+ * dh_auto_install: Create package build directory for those packages
+ whose makefile falls over otherwise. Closes: #707336
- -- Joey Hess <joeyh@debian.org> Tue, 07 May 2013 19:42:52 -0400
+ -- Joey Hess <joeyh@debian.org> Thu, 09 May 2013 10:34:56 -0400
debhelper (9.20130507) unstable; urgency=low
diff --git a/dh_auto_install b/dh_auto_install
index d513f2e2..ef46a3c5 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -80,6 +80,13 @@ if (!$destdir) {
}
$destdir = File::Spec->rel2abs($destdir, cwd());
+foreach my $package (@{$dh{DOPACKAGES}}) {
+ my $tmp=tmpdir($package);
+ if (! -e $tmp) {
+ doit("install","-d",$tmp);
+ }
+}
+
buildsystems_do("install", $destdir);
=head1 SEE ALSO