summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-07-19 17:49:11 +0000
committerjoey <joey>2005-07-19 17:49:11 +0000
commit7a61e2fd152ccfd631a693a9f295fe5f3d8e67a6 (patch)
treea44dc7bf84940e071c2b133fc29c7a726a66449f
parent78e828cbc2604324385a20f21083d929d0097ea9 (diff)
r1774: * dh_install: in v5 mode, error out if there are wildcards in the file
list and the wildcards expand to nothing. Done only for v5 as this is a behavior change.
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_install7
2 files changed, 14 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index fccb4357..a4cc5f5d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.9.5) UNRELEASED; urgency=low
+
+ * dh_install: in v5 mode, error out if there are wildcards in the file
+ list and the wildcards expand to nothing. Done only for v5 as this is a
+ behavior change.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 19 Jul 2005 13:48:52 -0400
+
debhelper (4.9.4) unstable; urgency=low
* dh_clean: switch to using complex_doit for the evil find command
diff --git a/dh_install b/dh_install
index d7c4161c..4ae15532 100755
--- a/dh_install
+++ b/dh_install
@@ -138,7 +138,12 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! defined $dh{AUTODEST} && @$set > 1) {
$dest=pop @$set;
}
- # glob now, relative to srcdir
+ if (! compat(4)) { # check added in v5
+ # glob now, relative to srcdir
+ if (! map { glob "$srcdir/$_" } @$set) {
+ error("missing files (@$set), aborting");
+ }
+ }
foreach my $src (map { glob "$srcdir/$_" } @$set) {
next if excludefile($src);