summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-05-11 17:44:02 +0000
committerjoey <joey>2001-05-11 17:44:02 +0000
commit7b068400acb737a64e1f8e5c6b23d72b8dd5c1eb (patch)
treeaca0c4615d54bd94ec588717a7009d1766acc5a4
parent653a744c8e6b4011874b79757129dae45f5bc229 (diff)
r465: * Modified the postrm fragment for dh_installxfonts to not try to delete
any files. The responsibility for doing so devolves onto update-fonts-* (which don't yet, but will). See bug #94752
-rw-r--r--autoscripts/postrm-xfonts17
-rw-r--r--debian/changelog8
2 files changed, 14 insertions, 11 deletions
diff --git a/autoscripts/postrm-xfonts b/autoscripts/postrm-xfonts
index 851b61f5..29cec435 100644
--- a/autoscripts/postrm-xfonts
+++ b/autoscripts/postrm-xfonts
@@ -10,18 +10,13 @@ makefontdir() {
fontdirs="#FONTDIRS#"
updatecmds="#UPDATECMDS#"
-for currentdir in $fontdirs; do
- longdir=/usr/lib/X11/fonts/$currentdir
- if [ -d $longdir ]; then
- for file in fonts.dir fonts.alias encodings.dir; do
- rm -f $longdir/$file
- done
- if [ $(find $longdir| wc -l) -eq 1 ]; then
- rmdir -p $longdir
- else
+if [ "$1" = "purge" -o "$1" = "remove" -o "$1" = "disappear" ]; then
+ for currentdir in $fontdirs; do
+ longdir=/usr/lib/X11/fonts/$currentdir
+ if [ -d $longdir ]; then
for currentcmd in $updatecmds; do
$currentcmd $longdir
done
fi
- fi
-done
+ done
+fi
diff --git a/debian/changelog b/debian/changelog
index 93b19999..027f3fac 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (3.0.20) unstable; urgency=low
+
+ * Modified the postrm fragment for dh_installxfonts to not try to delete
+ any files. The responsibility for doing so devolves onto update-fonts-*
+ (which don't yet, but will). See bug #94752
+
+ -- Joey Hess <joeyh@debian.org> Fri, 11 May 2001 13:30:43 -0400
+
debhelper (3.0.19) unstable; urgency=low
* Now uses html2text rather than lynx for converting html changelogs.