summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-11-07 13:52:00 -0400
committerJoey Hess <joey@kitenet.net>2011-11-07 13:52:00 -0400
commit7b8b4bd6dd7d26a4d9fbe62490cc7b2c722cc603 (patch)
treeac7454d2d2f80c0c361f9c5a9193384241236ece
parent53d7a9a22c1fb539558ca39dacc4bef8a02dca01 (diff)
dh_strip: In v9, pass --compress-debug-sections to objcopy. Needs a new enough binutils and gdb; debhelper backport may need to disable this. Thanks, Aurelien Jarno and Bastien ROUCARIES. Closes: #631985
-rw-r--r--debhelper.pod5
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_strip7
3 files changed, 20 insertions, 1 deletions
diff --git a/debhelper.pod b/debhelper.pod
index b85bc1a5..98da7362 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -481,6 +481,11 @@ explicit binary target with explicit dependencies on the other targets.
=item -
+B<dh_strip> compresses debugging symbol files to reduce the installed
+size of -dbg packages.
+
+=item -
+
B<dh_auto_configure> does not include the source package name
in --libexecdir when using autoconf.
diff --git a/debian/changelog b/debian/changelog
index fdf03d19..6ebb4d0d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (8.9.10) UNRELEASED; urgency=low
+
+ * dh_strip: In v9, pass --compress-debug-sections to objcopy.
+ Needs a new enough binutils and gdb; debhelper backport
+ may need to disable this.
+ Thanks, Aurelien Jarno and Bastien ROUCARIES. Closes: #631985
+
+ -- Joey Hess <joeyh@debian.org> Mon, 07 Nov 2011 13:50:30 -0400
+
debhelper (8.9.9) unstable; urgency=low
* dh_auto_build: Use target architecture (not host architecture)
diff --git a/dh_strip b/dh_strip
index a38a66be..aebc1009 100755
--- a/dh_strip
+++ b/dh_strip
@@ -166,7 +166,12 @@ sub make_debug {
if (! -d $debug_dir) {
doit("install", "-d", $debug_dir);
}
- doit($objcopy, "--only-keep-debug", $file, $debug_path);
+ if(compat(8)) {
+ doit($objcopy, "--only-keep-debug", $file, $debug_path);
+ }
+ else {
+ doit($objcopy, "--only-keep-debug --compress-debug-sections", $file, $debug_path);
+ }
# No reason for this to be executable.
doit("chmod", 644, $debug_path);
return $debug_path;