summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-02-25 07:36:49 +0000
committerjoey <joey>2001-02-25 07:36:49 +0000
commit811a51e68bf36e8116d5cb0f60fde617640cdcd3 (patch)
tree0c3507a622cfeaab59d6a94fa44c2a85eec46797
parent58a5fcfd24ecc319d4f5cc632d32ef31ef14079e (diff)
r449: * dh_perl update
-rw-r--r--Debian/Debhelper/Dh_Lib.pm4
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_perl8
3 files changed, 14 insertions, 4 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index e17913ed..5ed9d163 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -60,9 +60,7 @@ sub init {
# the default, doing them all.
if (! defined $dh{DOPACKAGES} || ! @{$dh{DOPACKAGES}}) {
if ($dh{DOINDEP} || $dh{DOARCH} || $dh{DOSAME}) {
- # User specified that all arch (in)dep package be
- # built, and there are none of that type.
- error("I have no package to act on");
+ error("You asked that all arch in(dep) packages be built, but there are none of that type.");
}
push @{$dh{DOPACKAGES}},@allpackages;
}
diff --git a/debian/changelog b/debian/changelog
index bd59672e..15109a62 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (3.0.8) unstable; urgency=low
+
+ * dh_perl update
+
+ -- Joey Hess <joeyh@debian.org> Sat, 24 Feb 2001 23:31:31 -0800
+
debhelper (3.0.7) unstable; urgency=low
* dh_makeshlibs: only generate call to ldconfig if it really looks like
diff --git a/dh_perl b/dh_perl
index 64cb362b..8bdfdad8 100755
--- a/dh_perl
+++ b/dh_perl
@@ -36,6 +36,12 @@ full perl package. If so, you can pass the -d option to make dh_perl generate
a dependency on the correct base package. This is only necessary for some
packages that are included in the base system.
+=item B<-V>
+
+By default, scripts and architecture independent modules don't depend
+on any specific version of perl. The -V option causes the current
+version of the perl (or perl-base with -d) package to be specified.
+
=item I<library dirs>
If your package installs perl modules in non-standard
@@ -107,7 +113,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my $perl_depends = $perl;
if ($deps & XS_MODULE or $dh{V_FLAG_SET})
{
- ($version) = `dpkg -p $perl` =~ /^Version:\s*(\S+)/m
+ ($version) = `dpkg -s $perl` =~ /^Version:\s*(\S+)/m
unless $version;
$perl_depends .= " (>= $version)";