summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2003-08-08 23:13:18 +0000
committerjoey <joey>2003-08-08 23:13:18 +0000
commit8406a1dbd219c99c3039d66c158fb842a2fb0833 (patch)
tree8d9b738838f1a3feff7e93f7963bc2f6acdf3010
parent742d35523bbb24a4da8860f0a46701244dd5e214 (diff)
r1582: * dh_makeshlibs: only scan files matching *.so.* and *.so, not *.so*.
Closes: #204559
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_makeshlibs2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2898f71b..a9f3786e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.61) unstable; urgency=low
+
+ * dh_makeshlibs: only scan files matching *.so.* and *.so, not *.so*.
+ Closes: #204559
+
+ -- Joey Hess <joeyh@debian.org> Fri, 8 Aug 2003 17:08:00 -0400
+
debhelper (4.1.60) unstable; urgency=low
* dh_python: support python ver 2.3. Closes: #204556
diff --git a/dh_makeshlibs b/dh_makeshlibs
index de9f7827..ba5266b8 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -104,7 +104,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {
$exclude="! \\( $dh{EXCLUDE_FIND} \\) ";
}
- open (FIND, "find $tmp -type f -name '*.so*' $exclude |");
+ open (FIND, "find $tmp -type f \\( -name '*.so' -or -name '*.so.*' \\) $exclude |");
while (<FIND>) {
my ($library, $major);
my $objdump=`objdump -p $_`;