summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2000-11-27 20:06:04 +0000
committerjoey <joey>2000-11-27 20:06:04 +0000
commit858d4ccaeb04f9c2ea9dd4083aca06dac25037e5 (patch)
tree138e7fa455fe48e7da16082e5c56a667d2a2f202
parent8ce86a9b3b01893d90c109d726c7ddcfb31538a8 (diff)
r394: * Reverted the change to make debian/README be treated as README.Debian,
after I learned people use it for eg, documenting the source package itself. Closes: #34628, since it seems this is not such an "incredibly minor" change after all. Never underetimate the annoyance of backwards-compatability.
-rw-r--r--debian/changelog10
-rwxr-xr-xdh_installdocs15
-rw-r--r--dh_installdocs.110
-rw-r--r--doc/v34
4 files changed, 17 insertions, 22 deletions
diff --git a/debian/changelog b/debian/changelog
index 1930e77c..c43333ae 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+debhelper (2.2.1) unstable; urgency=low
+
+ * Reverted the change to make debian/README be treated as README.Debian,
+ after I learned people use it for eg, documenting the source package
+ itself. Closes: #34628, since it seems this is not such an "incredibly
+ minor" change after all. Never underetimate the annoyance of
+ backwards-compatability.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 27 Nov 2000 12:01:52 -0800
+
debhelper (2.2.0) unstable; urgency=low
* DH_COMPAT=3 now enables the following new features which I can't just
diff --git a/dh_installdocs b/dh_installdocs
index 50bc1712..7af38094 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -39,21 +39,10 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
$readme_debian=pkgfile($PACKAGE,'README.Debian');
if (! $readme_debian) {
$readme_debian=pkgfile($PACKAGE,'README.debian');
- if (! $readme_debian) {
- $readme_debian=pkgfile($PACKAGE,'README');
- }
}
if ($readme_debian) {
- if (isnative($PACKAGE)) {
- doit("install","-g",0,"-o",0,"-m","644","-p",
- $readme_debian,
- "$TMP/usr/share/doc/$PACKAGE/README");
- }
- else {
- doit("install","-g",0,"-o",0,"-m","644","-p",
- $readme_debian,
- "$TMP/usr/share/doc/$PACKAGE/README.Debian");
- }
+ doit("install","-g",0,"-o",0,"-m","644","-p","$readme_debian",
+ "$TMP/usr/share/doc/$PACKAGE/README.Debian");
}
$todo=pkgfile($PACKAGE,'TODO');
diff --git a/dh_installdocs.1 b/dh_installdocs.1
index 5f2bf993..7cc0623f 100644
--- a/dh_installdocs.1
+++ b/dh_installdocs.1
@@ -19,13 +19,13 @@ package dh_installdocs is told to act on. By default, this is the first
binary package in debian/control, but if you use -p, -i, or -a flags, it
will be the first package specified by those flags.
.P
-Also, debian/README (or debian/README.Debian) and debian/TODO, if
+Also, debian/README.Debian (or debian/README.debian) and debian/TODO, if
they exist, will be installed into the first binary package listed in
debian/control, if dh_installdocs is acting on that package. Note that
-they will be named README.Debian and TODO.Debian, if the package is not a
-debian native package, and README and TODO if it is. Also note that
-Additionally, debian/package.README and debian/package.TODO can be used
-to specify files for subpackages.
+debian/TODO will be installed named TODO.Debian, if the package is not a
+debian native package. Also note that README.debian is installed as
+README.Debian, for consitency. Note that debian/package.README.Debian and
+debian/package.TODO can be used to specify files for subpackages.
.P
Files named debian/package.docs can list other files to be installed.
.P
diff --git a/doc/v3 b/doc/v3
index 1f38b83c..3d5ebb61 100644
--- a/doc/v3
+++ b/doc/v3
@@ -25,10 +25,6 @@ them.
the .man filenames properly. It'll probably just assume all man pages have
an extension, and delete that extentation, and add the correct one.
-+ debian/README is installed as /usr/share/doc/<package>/README in
- native packages, and as README.Debian in non-native packages. This is
- consistent with the handing of debian/TODO and debian/changelog.
-
* There will be no change to the names of debhelper config files used, I've
decided against debian/<package>/* and the like, because although those
subdirs do work, they're not allowed by the packaging manual, and they'd