summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-09-10 13:58:42 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-09-10 13:58:42 -0400
commit877b24da5966777f63c2003b9e3654efbcfc68b0 (patch)
tree26b6d6e4694d1e62ed6782b3a3f26e5391c57014
parent111a25b53e382cf63e27a3b068a012da834defcc (diff)
dh_installchangelogs: Fall back to looking for changelog files ending with ".txt". Closes: #498460
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installchangelogs2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2f107939..ebcb3818 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.0.18) UNRELEASED; urgency=low
+
+ * dh_installchangelogs: Fall back to looking for changelog files ending
+ with ".txt". Closes: #498460
+
+ -- Joey Hess <joeyh@debian.org> Wed, 10 Sep 2008 13:58:00 -0400
+
debhelper (7.0.17) unstable; urgency=low
[ Per Olofsson ]
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 7042c5f9..a5cce3f4 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -68,7 +68,7 @@ my $changelog_name="changelog.Debian";
if (! defined $upstream) {
if (! isnative($dh{MAINPACKAGE}) && !compat(6)) {
my @files=sort glob("*");
- foreach my $name (qw{changelog changes}) {
+ foreach my $name (qw{changelog changes changelog.txt changes.txt}) {
my @matches=grep { lc $_ eq $name && -s $_ } @files;
if (@matches) {
$upstream=shift @matches;