summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2009-08-05 14:12:02 -0400
committerJoey Hess <joey@kitenet.net>2009-08-05 14:12:02 -0400
commit8bea5baf77f7d0cd56d4c66c4c3f7c33d28b506a (patch)
tree3cd6c5bbc897e4bffec260143a746b0150901676
parent7d18a1d8861e8b3c209f9e7782d76af59535a1e5 (diff)
parent7b1e681929b2ff7881dd130c22889dcab184a80e (diff)
Merge branch 'master' of ssh://git.debian.org/git/debhelper/debhelper
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm2
-rw-r--r--debian/changelog6
2 files changed, 7 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index 88bcff58..8974be2e 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -61,7 +61,7 @@ sub install {
sub clean {
my $this=shift;
- if (-f "Build") {
+ if (-e $this->get_sourcepath("Build")) {
$this->do_perl("Build", "--allow_mb_mismatch", 1, "distclean", @_);
}
}
diff --git a/debian/changelog b/debian/changelog
index f5f7487f..ae3846c3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.3.11) unstable; urgency=low
+
+ * perl_build: Fix Build check to honor source directory setting.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 05 Aug 2009 13:52:34 -0400
+
debhelper (7.3.10) unstable; urgency=low
* perl_build: Avoid failing if forced to be used in dh_auto_clean