summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2003-06-20 01:22:45 +0000
committerjoey <joey>2003-06-20 01:22:45 +0000
commit8fbfd5ac20e05711e01d11f188f45228d09b1a23 (patch)
treebc4193b10b41b6c92ee3ae502ad27f81b13fd2d5
parent895f9cbcfd47a04e241dbae047354d81489ce27f (diff)
r591: * dh_python typo fix Closes: #197679
* dh_link: don't complain if tmp dir does not exist yet when doing pre-link scan.
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_link4
-rwxr-xr-xdh_python2
3 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index b7913c61..22b46915 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.48) unstable; urgency=low
+
+ * dh_python typo fix Closes: #197679
+ * dh_link: don't complain if tmp dir does not exist yet when doing pre-link
+ scan.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 19 Jun 2003 19:51:13 -0400
+
debhelper (4.1.47) unstable; urgency=low
* dh_install: recalculate automatic $dest eash time through the glob loop.
diff --git a/dh_link b/dh_link
index ab71c25c..6cb889cd 100755
--- a/dh_link
+++ b/dh_link
@@ -102,8 +102,8 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
error("parameters list a link without a destination.");
}
- # v4 only
- if (! compat(3)) {
+ # v4 only and only if there is a temp dir already
+ if (! compat(3) && -e $tmp) {
# Scan for existing links and add them to @links, so they
# are recreated policy conformant.
find(
diff --git a/dh_python b/dh_python
index d936f318..81da6da5 100755
--- a/dh_python
+++ b/dh_python
@@ -26,7 +26,7 @@ current major version, or on pythonX.Y if your scripts or modules need a
specific python version. The dependency will be substituted into your
package's control file wherever you place the token "${python:Depends}".
-If some modules need to be byte-compiled at build time, appropriate
+If some modules need to be byte-compiled at install time, appropriate
postinst and prerm scripts will be generated.
If you use this program, your package should build-depend on python.