summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-10-14 12:04:01 -0400
committerJoey Hess <joey@kitenet.net>2011-10-14 12:04:01 -0400
commit90adcc683565ff41b7d0bbf070589a157d8a26cd (patch)
tree44fcbd396e60200105f29754c8b3aa1b893f772b
parentb023550cd4256f0341c43860645b77c25f470509 (diff)
dh: Add dh_auto_configure parameter example. Closes: #645335
-rw-r--r--debian/changelog1
-rwxr-xr-xdh10
2 files changed, 6 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 85c49b70..9dbf3805 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ debhelper (8.9.9) UNRELEASED; urgency=low
* dh_auto_build: Use target architecture for build directory name.
Closes: #644553 Thanks, Tom Hughes
+ * dh: Add dh_auto_configure parameter example. Closes: #645335
-- Joey Hess <joeyh@debian.org> Thu, 06 Oct 2011 19:26:08 -0400
diff --git a/dh b/dh
index 3bcd069c..4eae4448 100755
--- a/dh
+++ b/dh
@@ -87,16 +87,16 @@ commands work with no additional options.
Often you'll want to pass an option to a specific debhelper command. The
easy way to do with is by adding an override target for that command.
-
+
#!/usr/bin/make -f
%:
dh $@
-
+
override_dh_strip:
dh_strip -Xfoo
-
- override_dh_installdocs:
- dh_installdocs README TODO
+
+ override_dh_auto_configure:
+ dh_auto_configure -- --with-foo --disable-bar
Sometimes the automated L<dh_auto_configure(1)> and L<dh_auto_build(1)>
can't guess what to do for a strange package. Here's how to avoid running