summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-06-09 14:05:24 +0000
committerjoey <joey>2005-06-09 14:05:24 +0000
commit90f4f5db1d9f9c5af67fa5e58f89211dc00c7fb2 (patch)
tree25cf52ccb0f38f4bf8b3855d6f2c854e976c404b
parent903c9aa3e29fcc81296838270a47424dfff8b7d0 (diff)
r1760: releasing version 4.2.37
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_python1
-rw-r--r--doc/PROGRAMMING7
3 files changed, 17 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ca8078e3..42a80213 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (4.2.37) unstable; urgency=low
+
+ * Document getpackages in PROGRAMMING.
+ * Patch from Jeff Bailey to make dh_python set $python_version if -V is
+ specified so it looks in the right site-packages directories.
+ Closes: #312661
+
+ -- Joey Hess <joeyh@debian.org> Thu, 9 Jun 2005 10:01:20 -0400
+
debhelper (4.2.36) unstable; urgency=low
* Spanish translation update for dh_installdebconf(1).
diff --git a/dh_python b/dh_python
index a2dde7b9..3bd2ac7a 100755
--- a/dh_python
+++ b/dh_python
@@ -96,6 +96,7 @@ foreach (@python_allversions) {
# Check for -V
my $usepython = "python$python_version";
if($dh{V_FLAG_SET}) {
+ $python_version = $dh{V_FLAG};
$usepython = $dh{V_FLAG};
$usepython =~ s/^/python/;
if (! grep { $_ eq $usepython } @python_allversions) {
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index 8151c3ef..4b19db5e 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -243,5 +243,12 @@ is_udeb($package)
file.
udeb_filename($package)
Returns the filename of the udeb package.
+getpackages($type)
+ Returns a list of packages in the control file.
+ Must pass "arch" or "indep" or "same" to specify arch-dependant or
+ -independant or same arch packages. If nothing is specified, returns all
+ packages.
+ As a side effect, populates %package_arches and %package_types with
+ the types of all packages (not only those returned).
-- Joey Hess <joeyh@debian.org>