summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoeyh <joeyh>2006-01-20 22:06:07 +0000
committerjoeyh <joeyh>2006-01-20 22:06:07 +0000
commit9294875cbb26268af70ec8a84fb9ff74c76cf957 (patch)
treee350e57a01227529c522ec1e20b3348cc203a4b5
parent14c13fe2e86ef9b41ad215b26ebf3d290e444449 (diff)
r1859: * Reverted change in 4.1.9, so generation of EXCLUDE_FIND escapes "." to
"\\.", which turns into "\." after being run through the shell, and prevents find from treating -X.svn as a regexp that matches files such as foo/svn.vim. (It's safe to do this now that all uses of EXCLUDE_FIND are via complex_doit(), which was not the case of dh_clean when this change was originally made.) Closes: #349070
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debian/changelog10
-rw-r--r--doc/PROGRAMMING4
3 files changed, 12 insertions, 4 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 7c0a18a4..80645abe 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -55,7 +55,7 @@ sub init {
foreach (@{$dh{EXCLUDE}}) {
my $x=$_;
$x=escape_shell($x);
- $x=~s/\./\\./g;
+ $x=~s/\./\\\\./g;
$dh{EXCLUDE_FIND}.="-regex .\\*$x.\\* -or ";
}
$dh{EXCLUDE_FIND}=~s/ -or $//;
diff --git a/debian/changelog b/debian/changelog
index e0318f78..f969c30a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,14 @@
debhelper (5.0.18) UNRELEASED; urgency=low
* Improved po4a cleaning. Closes: #348521
-
- -- Joey Hess <joeyh@debian.org> Wed, 18 Jan 2006 16:12:13 -0500
+ * Reverted change in 4.1.9, so generation of EXCLUDE_FIND escapes "." to
+ "\\.", which turns into "\." after being run through the shell, and
+ prevents find from treating -X.svn as a regexp that matches files such
+ as foo/svn.vim. (It's safe to do this now that all uses of EXCLUDE_FIND are
+ via complex_doit(), which was not the case of dh_clean when this change
+ was originally made.) Closes: #349070
+
+ -- Joey Hess <joeyh@debian.org> Fri, 20 Jan 2006 16:56:00 -0500
debhelper (5.0.17) unstable; urgency=low
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index b87a8c60..a33daeb0 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -102,7 +102,9 @@ switch variable description
EXCLUDE_FIND same as DH_EXCLUDE, except all items are put
into a string in a way that they will make
find find them. (Use ! in front to negate
- that, of course)
+ that, of course) Note that this should
+ only be used inside complex_doit(), not in
+ doit().
-x INCLUDE_CONFFILES
include conffiles. It's -x for obscure
historical reasons.