summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2007-11-02 23:21:03 -0400
committerJoey Hess <joey@kodama.kitenet.net>2007-11-02 23:21:03 -0400
commit92e38dee858cbb68f6f986d3faac3da48d714efc (patch)
tree714c87108e22a1f44b1e766c757dfb2bf02ec0a3
parent9226b1d07f2d65c3d7b43cf1d69947132a5cdab1 (diff)
* dh_icons: Now that GTK 2.12 has entered testing, use the much simpler to
call update-icon-caches command. Thanks, Josselin Mouette.
-rw-r--r--autoscripts/postinst-icons8
-rw-r--r--autoscripts/postrm-icons16
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_icons4
4 files changed, 9 insertions, 23 deletions
diff --git a/autoscripts/postinst-icons b/autoscripts/postinst-icons
index 951b613d..9e00f039 100644
--- a/autoscripts/postinst-icons
+++ b/autoscripts/postinst-icons
@@ -1,7 +1,3 @@
-if which gtk-update-icon-cache >/dev/null 2>&1; then
- for dir in #DIRLIST#; do
- if [ -f "$dir"/index.theme ] && [ -f "$dir"/icon-theme.cache ]; then
- gtk-update-icon-cache --force --quiet "$dir"
- fi
- done
+if which update-icon-caches >/dev/null 2>&1 ; then
+ update-icon-caches #DIRLIST#
fi
diff --git a/autoscripts/postrm-icons b/autoscripts/postrm-icons
index 87fd790b..9e00f039 100644
--- a/autoscripts/postrm-icons
+++ b/autoscripts/postrm-icons
@@ -1,15 +1,3 @@
-if [ "$1" = "remove" ]; then
- for dir in #DIRLIST#; do
- if [ -d "$dir" ]; then
- if [ -f "$dir"/index.theme ] && \
- [ -f "$dir"/icon-theme.cache ] && \
- which gtk-update-icon-cache >/dev/null 2>&1
- then
- gtk-update-icon-cache --force --quiet "$dir"
- else
- rm -f "$dir"/icon-theme.cache
- rmdir -p --ignore-fail-on-non-empty "$dir"
- fi
- fi
- done
+if which update-icon-caches >/dev/null 2>&1 ; then
+ update-icon-caches #DIRLIST#
fi
diff --git a/debian/changelog b/debian/changelog
index 403e7f6b..9b8b64c2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,8 +4,10 @@ debhelper (5.0.60) UNRELEASED; urgency=low
* Reword paragraph about debian/compress files to perhaps be more clear
about the debian/compress file. Closes: #448759
* dh_installdirs(1): Remove unnecessary caveat about slashes.
+ * dh_icons: Now that GTK 2.12 has entered testing, use the much simpler to
+ call update-icon-caches command. Thanks, Josselin Mouette.
- -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 21:33:41 -0400
+ -- Joey Hess <joeyh@debian.org> Fri, 02 Nov 2007 23:17:39 -0400
debhelper (5.0.59) unstable; urgency=low
diff --git a/dh_icons b/dh_icons
index aa077e47..3cf3d262 100755
--- a/dh_icons
+++ b/dh_icons
@@ -17,10 +17,10 @@ B<dh_icons> [S<I<debhelper options>>] [B<-n>]
=head1 DESCRIPTION
dh_icons is a debhelper program that updates Freedesktop icon caches
-when needed, using the gtk-update-icon-cache program provided by GTK+2.0.
+when needed, using the update-icon-caches program provided by GTK+2.12.
Currently this program does not handle installation of the files, though it
may do so at a later date. It takes care of adding maintainer script
-fragments to call F<gtk-update-icon-cache>.
+fragments to call F<update-icon-caches>.
=head1 OPTIONS