summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoeyh <joeyh>2006-12-26 21:28:05 +0000
committerjoeyh <joeyh>2006-12-26 21:28:05 +0000
commit985463e25f059565ef677985ebca02c7470efccf (patch)
treefba743eee347475b97b7538efd8a830ec2bca64e
parent2798d63f17c07ab17ef9f5434106af5ad9c65fc6 (diff)
r1965: * dh_fixperms: Change a chmod +x to chmod a+x, to avoid the umask
influencing it.
-rw-r--r--debian/changelog4
-rwxr-xr-xdh_fixperms2
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 2a416116..2660c0ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,10 @@ debhelper (5.0.43) UNRELEASED; urgency=low
[ Joey Hess ]
* Typo. Closes: #400571
+ * dh_fixperms: Change a chmod +x to chmod a+x, to avoid the umask
+ influencing it.
- -- Joey Hess <joeyh@debian.org> Mon, 27 Nov 2006 12:17:29 -0500
+ -- Joey Hess <joeyh@debian.org> Tue, 26 Dec 2006 16:26:57 -0500
debhelper (5.0.42) unstable; urgency=low
diff --git a/dh_fixperms b/dh_fixperms
index 775ab55e..a96b1e05 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -91,7 +91,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
for my $dir (qw{usr/bin bin usr/sbin sbin usr/games etc/init.d}) {
if (-d "$tmp/$dir") {
complex_doit("find $tmp/$dir -type f $find_options -print0 2>/dev/null",
- "| xargs -0r chmod +x");
+ "| xargs -0r chmod a+x");
}
}
}