summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2000-10-03 19:35:32 +0000
committerjoey <joey>2000-10-03 19:35:32 +0000
commit997faf950ed3e3fbb05d599ef739c9fe0aa7121d (patch)
tree8d2f830259b563f924743f3e534b35e5aee73843
parentb2b388b4d237da2e6b72a2fef141a9535ecdc36a (diff)
r376: * Rats, the previous change makes duplicate lines be created in the
shlibs file, and lintian conplains. Added some hackery that should prevent that. Closes: #73052
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_makeshlibs9
2 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6ae0b669..3342181b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (2.1.14) unstable; urgency=low
+
+ * Rats, the previous change makes duplicate lines be created in the
+ shlibs file, and lintian conplains. Added some hackery that should
+ prevent that. Closes: #73052
+
+ -- Joey Hess <joeyh@debian.org> Tue, 3 Oct 2000 12:32:22 -0700
+
debhelper (2.1.13) unstable; urgency=low
* Typo, Closes: #72932
diff --git a/dh_makeshlibs b/dh_makeshlibs
index bfded282..66781c7e 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -8,6 +8,8 @@ init();
foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
$TMP=tmpdir($PACKAGE);
+ my %seen;
+
doit("rm", "-f", "$TMP/DEBIAN/shlibs");
open (FIND, "find $TMP -xtype f -name '*.so.*' |");
@@ -34,7 +36,12 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
if (defined($library) && defined($major) && defined($deps) &&
$library ne '' && $major ne '' && $deps ne '') {
- complex_doit("echo '$library $major $deps' >>$TMP/DEBIAN/shlibs");
+ # Prevent duplicate lines from entering the file.
+ my $line="$library $major $deps";
+ if (! $seen{$line}) {
+ $seen{$line}=1;
+ complex_doit("echo '$line' >>$TMP/DEBIAN/shlibs");
+ }
}
}
close FIND;