summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-08-04 22:53:01 +0000
committerjoey <joey>2002-08-04 22:53:01 +0000
commit99a3ec036f753431d19b2032ab9d978a269b85b2 (patch)
tree842f2e6d4c24b6b66acb3a63c1b61abca1f07a2d
parent749200052597fab71422b420b484c62a97accf9e (diff)
r542: * dh_installinit: Always start daemon on upgraded even if
--no-restart-on-upgrade is given; since the daemon is not stopped with that parameter starting it again is a no-op, unless the daemon was not running for some reason. This makes transtions to using the flag easier. Closes: #90976 and sorry it took me so long to verify you were right.
-rw-r--r--autoscripts/postinst-init-norestart8
-rw-r--r--autoscripts/postinst-init-norestart-invoke8
-rw-r--r--debian/changelog11
-rwxr-xr-xdh_installinit9
4 files changed, 15 insertions, 21 deletions
diff --git a/autoscripts/postinst-init-norestart b/autoscripts/postinst-init-norestart
deleted file mode 100644
index a5741654..00000000
--- a/autoscripts/postinst-init-norestart
+++ /dev/null
@@ -1,8 +0,0 @@
-if [ -x "/etc/init.d/#SCRIPT#" ]; then
- update-rc.d #SCRIPT# #INITPARMS# >/dev/null
- if [ "$1" = "configure" ]; then
- if [ -z "$2" ] || [ "$2" = "<unknown>" ]; then
- /etc/init.d/#SCRIPT# start
- fi
- fi
-fi
diff --git a/autoscripts/postinst-init-norestart-invoke b/autoscripts/postinst-init-norestart-invoke
deleted file mode 100644
index be1751c8..00000000
--- a/autoscripts/postinst-init-norestart-invoke
+++ /dev/null
@@ -1,8 +0,0 @@
-if [ -x "/etc/init.d/#SCRIPT#" ]; then
- update-rc.d #SCRIPT# #INITPARMS# >/dev/null
- if [ "$1" = "configure" ]; then
- if [ -z "$2" ] || [ "$2" = "<unknown>" ]; then
- invoke-rc.d #SCRIPT# start
- fi
- fi
-fi
diff --git a/debian/changelog b/debian/changelog
index 86473030..709e49c3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+debhelper (4.1.3) unstable; urgency=low
+
+ * dh_installinit: Always start daemon on upgraded even if
+ --no-restart-on-upgrade is given; since the daemon is not stopped
+ with that parameter starting it again is a no-op, unless the daemon was
+ not running for some reason. This makes transtions to using the flag
+ easier. Closes: #90976 and sorry it took me so long to verify you were
+ right.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 4 Aug 2002 18:52:12 -0400
+
debhelper (4.1.2) unstable; urgency=low
* Typo, Closes: #155323
diff --git a/dh_installinit b/dh_installinit
index 8af1751e..b20a1114 100755
--- a/dh_installinit
+++ b/dh_installinit
@@ -150,17 +150,16 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
addsubstvar($package, "misc:Depends", "sysvinit", ">= 2.80-1");
$substvaradded=1;
}
+ autoscript($package,"postinst", "postinst-init$tailstr",
+ "s/#SCRIPT#/$script/;s/#INITPARMS#/$params/");
# -r on the command line sets R_FLAG. If it's set,
- # there is no restart on upgrade.
+ # there is no restart on upgrade, so don't stop
+ # daemon. (It's ok that it's always started.)
if ($dh{R_FLAG}) {
- autoscript($package,"postinst", "postinst-init-norestart$tailstr",
- "s/#SCRIPT#/$script/;s/#INITPARMS#/$params/");
autoscript($package,"prerm","prerm-init-norestart$tailstr",
"s/#SCRIPT#/$script/;s/#INITPARMS#/$params/");
}
else {
- autoscript($package,"postinst","postinst-init$tailstr",
- "s/#SCRIPT#/$script/;s/#INITPARMS#/$params/");
autoscript($package,"prerm","prerm-init$tailstr",
"s/#SCRIPT#/$script/;s/#INITPARMS#/$params/");
}