summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2000-11-30 05:03:37 +0000
committerjoey <joey>2000-11-30 05:03:37 +0000
commit9b53dab3959087e387b73f0a573172fdc910e737 (patch)
treefee1110426b35eaba1489fb50df622577c2d0e8f
parent5af47d4815bf66905cb224bdf7efdb093419a503 (diff)
r400: * Oops, it was not expanding wildcard when it should.
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_movefiles2
3 files changed, 8 insertions, 2 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 52adf66a..db2a1cf5 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -354,7 +354,7 @@ sub filearray {
# The tricky bit is that the glob expansion is done
# as if we were in the specified directory, so the
# filenames that come out are relative to it.
- if (defined $globdir && compat(3)) {
+ if (defined $globdir && ! compat(2)) {
for (map { glob "$globdir/$_" } split) {
s#^$globdir/##;
push @ret, $_;
diff --git a/debian/changelog b/debian/changelog
index 80af3efa..0e88c579 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (2.2.5) unstable; urgency=low
+
+ * Oops, it was not expanding wildcard when it should.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 29 Nov 2000 20:59:33 -0800
+
debhelper (2.2.4) unstable; urgency=low
* dh_movefiles: added error message on file not found
diff --git a/dh_movefiles b/dh_movefiles
index cbfc3e6c..be46dcb3 100755
--- a/dh_movefiles
+++ b/dh_movefiles
@@ -43,7 +43,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
# Now we need to expand wildcards in @tomove.
# This is only necessary in pre-v3 land -- as of v3, the
# expension is automatically done by filearray().
- if (@tomove && ! Debian::Debhelper::Dh_Lib::compat(3)) {
+ if (@tomove && Debian::Debhelper::Dh_Lib::compat(2)) {
@filelist=();
foreach (@tomove) {
push @filelist, glob("$sourcedir/$_");