summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-19 16:41:30 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-19 16:41:30 -0400
commit9ce9e30c584de00dff711c5f69e2da85184d04d6 (patch)
tree61cbcee0d8c333feef82a06ef8f100de0634f36f
parentb2fcc49059c2133a2f989a6fc163d3c11c188fd1 (diff)
dh_icons: Support .xpm format icons. Stop looking for .jpg icons, and also, for compleness, support .icon files. This matches the set of extensions supported by gtk-update-icon-cache. Closes: #448094
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_icons2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 40dc133e..76e06707 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (6.0.12) UNRELEASED; urgency=low
+
+ * dh_icons: Support .xpm format icons. Stop looking for .jpg icons, and
+ also, for compleness, support .icon files. This matches the set of
+ extensions supported by gtk-update-icon-cache. Closes: #448094
+
+ -- Joey Hess <joeyh@debian.org> Sat, 19 Apr 2008 16:38:43 -0400
+
debhelper (6.0.11) unstable; urgency=medium
* dh_installman: man --recode transparently uncompresses compressed
diff --git a/dh_icons b/dh_icons
index 3cf3d262..355a85bc 100755
--- a/dh_icons
+++ b/dh_icons
@@ -46,7 +46,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
next if $subdir =~ /^\./;
my $needs_cache = 0;
find sub {
- $needs_cache = 1 if -f and (/\.png$/ or /\.svg$/ or /\.jpg$/);
+ $needs_cache = 1 if -f and (/\.png$/ or /\.svg$/ or /\.xpm$/ or /\.icon$/);
}, "$icondir/$subdir" ;
push @dirlist, "$baseicondir/$subdir" if $needs_cache;
}