summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>1999-09-11 20:13:25 +0000
committerjoey <joey>1999-09-11 20:13:25 +0000
commit9d3fce399b4344e7a0453abcc90c1bf74bd6d10d (patch)
tree77a483786c5c2bd26d4ab91ce28b364ca1befa89
parenta115415a3f6d57cef2110490a9f7d0f0dc62d14c (diff)
r272: * dh_compress: fixed #ARGV bug (again) Closes: #44853
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_compress2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 50050098..a770e735 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (2.0.44) unstable; urgency=low
+
+ * dh_compress: fixed #ARGV bug (again) Closes: #44853
+
+ -- Joey Hess <joeyh@master.debian.org> Sat, 11 Sep 1999 13:04:15 -0700
+
debhelper (2.0.43) unstable; urgency=low
* Corrected example rules files, which had some messed up targets.
diff --git a/dh_compress b/dh_compress
index 847bcb6d..1312bf46 100755
--- a/dh_compress
+++ b/dh_compress
@@ -22,7 +22,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
@files=();
# First of all, deal with any files specified right on the command line.
if (($PACKAGE eq $dh{FIRSTPACKAGE} || $dh{PARAMS_ALL}) && @ARGV) {
- push @files,#ARGV;
+ push @files, @ARGV;
}
if ($compress) {
# The config file is a sh script that outputs the files to be compressed