summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoeyh <joeyh>2007-09-18 22:18:55 +0000
committerjoeyh <joeyh>2007-09-18 22:18:55 +0000
commit9df3c2d67cf20d04adda19eed55d70d866c51b16 (patch)
tree4be6dee34aa7a79d99a09b658b1adb88902512dd
parentf82a4edc9bd999fe6425f930320897f309a6fdb7 (diff)
r2030: * dh_installmodules: Since modutils is gone, stop supporting
debian/*.modutils files. Warn about such files. Closes: #443127
-rw-r--r--autoscripts/postinst-update-modules5
-rw-r--r--autoscripts/postrm-update-modules3
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installmodules20
4 files changed, 15 insertions, 20 deletions
diff --git a/autoscripts/postinst-update-modules b/autoscripts/postinst-update-modules
deleted file mode 100644
index f5e13b56..00000000
--- a/autoscripts/postinst-update-modules
+++ /dev/null
@@ -1,5 +0,0 @@
-if [ "$1" = "configure" ]; then
- if [ -x "`which update-modules 2>/dev/null`" ]; then
- update-modules >/dev/null || [ "$?" = 3 ]
- fi
-fi
diff --git a/autoscripts/postrm-update-modules b/autoscripts/postrm-update-modules
deleted file mode 100644
index 35db8718..00000000
--- a/autoscripts/postrm-update-modules
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x "`which update-modules 2>/dev/null`" ]; then
- update-modules >/dev/null || [ "$?" = 3 ]
-fi
diff --git a/debian/changelog b/debian/changelog
index 6088ee94..ce972462 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.56) unstable; urgency=low
+
+ * dh_installmodules: Since modutils is gone, stop supporting
+ debian/*.modutils files. Warn about such files. Closes: #443127
+
+ -- Joey Hess <joeyh@debian.org> Tue, 18 Sep 2007 18:16:13 -0400
+
debhelper (5.0.55) unstable; urgency=low
* dh_desktop: Only generate calls to update-desktop-database for desktop
diff --git a/dh_installmodules b/dh_installmodules
index 99dcc31a..2d1d5969 100755
--- a/dh_installmodules
+++ b/dh_installmodules
@@ -20,9 +20,7 @@ B<dh_installmodules> [S<I<debhelper options>>] [B<-n>] [B<--name=>I<name>]
dh_installmodules is a debhelper program that is responsible for
registering kernel modules.
-Files named debian/package.modules will be installed as
-etc/modutils/package in the package build directory. This is for use by
-modutils. Files named debian/package.modprobe will be installed in
+Files named debian/package.modprobe will be installed in
etc/modprobe.d/package in the package build directory, to be used by
module-init-tools's version of modprobe.
@@ -32,6 +30,12 @@ run depmod and register the modules when the package is installed.
These commands are inserted into the maintainer scripts by dh_installdeb.
See L<dh_installdeb(1)> for an explanation of how this works.
+Previous versions of dh_installmodules also supported
+files named debian/package.modules, which were installed into
+etc/modutils/package in the package build directory. This was for use by
+modutils, which is no longer in Debian. dh_installmodules will warn about
+such files now.
+
=head1 OPTIONS
=over 4
@@ -91,10 +95,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if ($modutils_file) {
- if (! -e "$tmp/etc/modutils") {
- doit("install","-d","$tmp/etc/modutils");
- }
- doit("install","-m","0644",$modutils_file,"$tmp/etc/modutils/".pkgfilename($package));
+ warning("ignoring $modutils_file, since modutils is no longer in Debian");
}
if ($modprobe_file) {
@@ -105,11 +106,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if (! $dh{NOSCRIPTS}) {
- if ($modutils_file) {
- autoscript($package,"postinst","postinst-update-modules");
- autoscript($package,"postrm","postrm-update-modules");
- }
-
foreach my $kvers (find_kernel_modules("$tmp/lib/modules")) {
autoscript($package,"postinst","postinst-modules","s/#KVERS#/$kvers/g");
autoscript($package,"postrm","postrm-modules","s/#KVERS#/$kvers/g");