summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-05-07 13:18:01 -0400
committerJoey Hess <joey@kitenet.net>2013-05-07 13:18:01 -0400
commita30b483726eebd4a76370c9ec22fdde23955df59 (patch)
tree7887a39f55b21d238fa6c2256de90c04804bdf90
parent2bb8664eb6b822d40d23ffd55c64ff538849df77 (diff)
Revert python2.X-minimal fix, because it was buggy. Closes: #707111 (Reopens #683557)
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm9
-rw-r--r--debian/changelog2
2 files changed, 3 insertions, 8 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index fd317306..4795b7c3 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -155,14 +155,7 @@ sub setup_py {
}
foreach my $python (@python_dbg, @python_requested) {
- my $python_with_version = $python;
- if ($python eq "python") {
- $python_with_version = $python_default;
- }
- elsif ($python eq "python-dbg") {
- $python_with_version = $python_default."-dbg";
- }
- if (-f "/usr/lib/$python_with_version/distutils/__init__.py") {
+ if (-x "/usr/bin/".$python) {
# To allow backports of debhelper we don't pass
# --install-layout=deb to 'setup.py install` for
# those Python versions where the option is
diff --git a/debian/changelog b/debian/changelog
index d27015c0..6fafb7c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,8 @@ debhelper (9.20130505) UNRELEASED; urgency=low
running make -n to test for the existance of targets.
In some makefiles, the parameters may be necessary to enable a target.
Closes: #706923
+ * Revert python2.X-minimal fix, because it was buggy.
+ Closes: #707111 (Reopens #683557)
-- Joey Hess <joeyh@debian.org> Sun, 05 May 2013 11:34:20 -0400