summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>1999-12-01 21:40:28 +0000
committerjoey <joey>1999-12-01 21:40:28 +0000
commita57e9b713e0bc24cae3424bca29bb500126930f9 (patch)
tree815837a9d1e022e64adc8826704deb4490c2f4ef
parent1293ba59fbfd430080036ab3bda6941461231c28 (diff)
r322: * dh_fixperms: chown symlinks as well as normal files. Closes: #51169.
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_fixperms4
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8822c154..056d7b10 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (2.0.78) unstable; urgency=low
+
+ * dh_fixperms: chown symlinks as well as normal files. Closes: #51169.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 1 Dec 1999 13:34:06 -0800
+
debhelper (2.0.77) unstable; urgency=low
* dh_suidregister: Fixed a rather esoteric bug: If a file had multiple
diff --git a/dh_fixperms b/dh_fixperms
index 0ad5c605..98201e94 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -17,8 +17,8 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
# General permissions fixing.
- complex_doit("find $TMP ! -type l $find_options -print0",
- "2>/dev/null | xargs -0r chown root.root");
+ complex_doit("find $TMP $find_options -print0",
+ "2>/dev/null | xargs -0r chown --no-dereference root.root");
complex_doit("find $TMP ! -type l $find_options -print0",
"2>/dev/null | xargs -0r chmod go=rX,u+rw,a-s");