summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-11-17 00:15:32 -0400
committerJoey Hess <joey@kitenet.net>2011-11-17 00:15:32 -0400
commita870aa095247275de6f791ddbcd098fb51cbee47 (patch)
treea00efacc54ce84ced40dd3da6927d1afa806e92c
parent4e6ddeaa95407f58b4817e029b42d3c18f4c764d (diff)
Fix broken option passing to objcopy. Closes: #649044
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_strip2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 261dba60..f51a2eb4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (8.9.11) UNRELEASED; urgency=low
+
+ * Fix broken option passing to objcopy. Closes: #649044
+
+ -- Joey Hess <joeyh@debian.org> Thu, 17 Nov 2011 00:15:10 -0400
+
debhelper (8.9.10) unstable; urgency=low
* dh_strip: In v9, pass --compress-debug-sections to objcopy.
diff --git a/dh_strip b/dh_strip
index ae1594fe..4dc69616 100755
--- a/dh_strip
+++ b/dh_strip
@@ -170,7 +170,7 @@ sub make_debug {
doit($objcopy, "--only-keep-debug", $file, $debug_path);
}
else {
- doit($objcopy, "--only-keep-debug --compress-debug-sections", $file, $debug_path);
+ doit($objcopy, "--only-keep-debug", "--compress-debug-sections", $file, $debug_path);
}
# No reason for this to be executable.
doit("chmod", 644, $debug_path);