summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-08-30 11:05:19 -0400
committerJoey Hess <joey@kitenet.net>2012-08-30 11:23:19 -0400
commitb3c00de156adf9c52da3cd0fa7c46414d5eb6982 (patch)
tree3c18eab279008d18aa930377cc223d6917177a11
parentbf6781f75d757e674607a9bafd658e6f11fa3963 (diff)
dh_installcatalogs: Adjust catalog conffile conversion to avoid dpkg conffile prompt when upgrading from a removed package. Closes: #81194
-rw-r--r--autoscripts/preinst-sgmlcatalog5
-rw-r--r--debian/changelog8
2 files changed, 11 insertions, 2 deletions
diff --git a/autoscripts/preinst-sgmlcatalog b/autoscripts/preinst-sgmlcatalog
index 41f55d6d..96f06738 100644
--- a/autoscripts/preinst-sgmlcatalog
+++ b/autoscripts/preinst-sgmlcatalog
@@ -1,7 +1,8 @@
-if [ "$1" = "upgrade" ] && ! dpkg-query -S #CENTRALCAT# >/dev/null 2>&1; then
+if test -f #CENTRALCAT# -a "(" "$1" = "upgrade" -o "$1" = "install" -a -n "$2" ")" &&
+ ! dpkg-query -S #CENTRALCAT# >/dev/null 2>&1; then
# If the dpkg-query command returns non-zero, the central catalog is
# not owned by any package. This is due to an old behaviour of
# debhelper. Now that file becomes a conffile. In order to avoid a
# question during installation, we remove the old non-conffile.
- rm -f #CENTRALCAT#
+ mv #CENTRALCAT# #CENTRALCAT#.old
fi
diff --git a/debian/changelog b/debian/changelog
index 0bb44d67..b4d4824d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (9.20120830) unstable; urgency=low
+
+ * dh_installcatalogs: Adjust catalog conffile conversion to avoid
+ dpkg conffile prompt when upgrading from a removed package.
+ Closes: #681194
+
+ -- Joey Hess <joeyh@debian.org> Thu, 30 Aug 2012 11:04:10 -0400
+
debhelper (9.20120608) unstable; urgency=low
* dh: When there's an -indep override target without -arch, or vice versa,