summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-10-09 19:26:10 +0000
committerjoey <joey>2001-10-09 19:26:10 +0000
commitbb01ed16298d0c20e7987e70e77759c787607f8d (patch)
tree983a79edaacf40409f2102ef74e9f59ab1bab741
parent8b9ead7b1fa7319722a15a367b87ecdfd7ab9891 (diff)
r493: * dh_installman: documented translated man page support, and made it work
properly. It was not stripping the language part from the installed filenames.
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_installman15
-rw-r--r--doc/PROGRAMMING2
3 files changed, 19 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 7a590f7e..69f72eb6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (3.0.47) unstable; urgency=low
+
+ * dh_installman: documented translated man page support, and made it work
+ properly. It was not stripping the language part from the installed
+ filenames.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 9 Oct 2001 15:16:18 -0400
+
debhelper (3.0.46) unstable; urgency=low
* Typo, Closes: #114135
diff --git a/dh_installman b/dh_installman
index d8585aa2..c5efe70c 100755
--- a/dh_installman
+++ b/dh_installman
@@ -16,11 +16,12 @@ use Debian::Debhelper::Dh_Lib;
=head1 DESCRIPTION
-dh_installman is a debhelper program that handles for installing
+dh_installman is a debhelper program that handles installing
man pages into the correct locations in package build directories. You tell
it what man pages go in your packages, and it figures out where to
install them based on the section field in their .TH line and their filename
-extention.
+extention. It also supports translated man pages, by looking for extentions
+like .ll.8 and .ll_LL.8
Any man page filenames specified as parameters will be installed into the
first package dh_installman is told to act on. By default, this is the
@@ -115,19 +116,21 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
error("Could not determine section for $page");
}
+ # Get the man page's name -- everything up to the last dot.
+ my ($instname)=$basename=~m/^(.*)\./;
+
my $destdir="$tmp/usr/share/man/man$realsection/";
# Translated man pages are typically specified by adding the
# language code to the filename, so detect that and
- # redirect to appropriate directory.
+ # redirect to appropriate directory, stripping the code.
my ($langcode)=$basename=~m/.*\.([a-z][a-z](?:_[A-Z][A-Z])?)\.(?:[1-9]|man)/;
if (defined $langcode && $langcode ne '') {
$destdir="$tmp/usr/share/man/$langcode/man$section/";
+ # Strip the language code from the instname.
+ $instname=~s/\.$langcode$//;
}
$destdir=~tr:/:/:s; # just for looks
- # Get the man page's name -- everything up to the last dot.
- my ($instname)=$basename=~m/^(.*)\./;
-
if (! -e "$destdir/$instname.$section" &&
! -l "$destdir/$instname.$section") {
if (! -d $destdir) {
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index a1fa8ee7..69302d34 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -1,4 +1,6 @@
This file documents things you should know to write a new debhelper program.
+Any program with a name that debins with dh_ should conform to these
+guidelines (with the historical exception of dh_make).
Standardization:
---------------