summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoeyh <joeyh>2006-06-12 01:40:56 +0000
committerjoeyh <joeyh>2006-06-12 01:40:56 +0000
commitbf38096fa55c43807885d5c531a067f5781a945b (patch)
tree4034404a2b8ca2c448dca07ab31d51d73fbfe841
parent4ac0a7b9288220f00c948225ac659419ffc08110 (diff)
r1932: split the scripts for the two cases, undo behavior change
-rw-r--r--autoscripts/postinst-modules3
-rw-r--r--autoscripts/postinst-update-modules5
-rw-r--r--autoscripts/postrm-modules3
-rw-r--r--autoscripts/postrm-update-modules3
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installmodules5
6 files changed, 15 insertions, 11 deletions
diff --git a/autoscripts/postinst-modules b/autoscripts/postinst-modules
index 0460eaaf..f17dc2da 100644
--- a/autoscripts/postinst-modules
+++ b/autoscripts/postinst-modules
@@ -1,7 +1,4 @@
if [ "$1" = "configure" ]; then
- if [ -x "`which update-modules 2>/dev/null`" ]; then
- update-modules >/dev/null || [ "$?" = 3 ]
- fi
if [ -e /boot/System.map-#KVERS# ]; then
depmod -a -F /boot/System.map-#KVERS# #KVERS# || true
fi
diff --git a/autoscripts/postinst-update-modules b/autoscripts/postinst-update-modules
new file mode 100644
index 00000000..f5e13b56
--- /dev/null
+++ b/autoscripts/postinst-update-modules
@@ -0,0 +1,5 @@
+if [ "$1" = "configure" ]; then
+ if [ -x "`which update-modules 2>/dev/null`" ]; then
+ update-modules >/dev/null || [ "$?" = 3 ]
+ fi
+fi
diff --git a/autoscripts/postrm-modules b/autoscripts/postrm-modules
index d710791d..c2577dd2 100644
--- a/autoscripts/postrm-modules
+++ b/autoscripts/postrm-modules
@@ -1,6 +1,3 @@
-if [ -x "`which update-modules 2>/dev/null`" ]; then
- update-modules >/dev/null || [ "$?" = 3 ]
-fi
if [ -e /boot/System.map-#KVERS# ]; then
depmod -a -F /boot/System.map-#KVERS# #KVERS# || true
fi
diff --git a/autoscripts/postrm-update-modules b/autoscripts/postrm-update-modules
new file mode 100644
index 00000000..35db8718
--- /dev/null
+++ b/autoscripts/postrm-update-modules
@@ -0,0 +1,3 @@
+if [ -x "`which update-modules 2>/dev/null`" ]; then
+ update-modules >/dev/null || [ "$?" = 3 ]
+fi
diff --git a/debian/changelog b/debian/changelog
index 923ae6c6..2a9d2438 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-debhelper (5.0.37) UNRELEASED; urgency=low
+debhelper (5.0.37) unstable; urgency=low
* dh_installmodules: depmod -a is no longer run during boot, so if a module
package is installed for a kernel other than the running kernel, just
@@ -6,14 +6,11 @@ debhelper (5.0.37) UNRELEASED; urgency=low
depmod -a -F /boot/System.map-<kvers> <kvers>
The kernel version is guessed at based on the path to the modules in the
package. Closes: #301424
- * Note: behavior change due to the above: The mere existence of a
- debian/package.modules file will no longer make dh_installmodules add code
- to maintainer scripts.
* dh_installxfonts: In postrm, run the deregistraton code even on upgrade,
in case an upgrade involves moving fonts around (or removing or renaming
fonts). Closes: #372686
- -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 12:29:14 -0400
+ -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 21:17:38 -0400
debhelper (5.0.36) unstable; urgency=low
diff --git a/dh_installmodules b/dh_installmodules
index f3e8cc84..6b996a58 100755
--- a/dh_installmodules
+++ b/dh_installmodules
@@ -104,6 +104,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if (! $dh{NOSCRIPTS}) {
+ if ($modutils_file) {
+ autoscript($package,"postinst","postinst-update-modules");
+ autoscript($package,"postrm","postrm-update-modules");
+ }
+
foreach my $kvers (find_kernel_modules("$tmp/lib/modules")) {
autoscript($package,"postinst","postinst-modules","s/#KVERS#/$kvers/g");
autoscript($package,"postrm","postrm-modules","s/#KVERS#/$kvers/g");